
75Create a Map

Map Composer

Introduction The ERDAS IMAGINE Map Composer is an editor for creating 
cartographic-quality maps and presentation graphics. Maps can 
include single or multiple continuous raster layers, thematic (GIS) 
layers, vector layers, and annotation layers. 

Map Composer’s extensive annotation capabilities allow you to 
automatically generate text, legends, scale bars, grid lines, tick 
marks, borders, symbols, and more. You can select from over 16 
million colors, multiple line styles, and over 60 text fonts.

Approximate completion time for this tour guide is 40 minutes.

Create a Map In this tutorial, you create a map using the file 
modeler_output.img in the <ERDAS_Data_Home>/examples 
directory. This file contains SPOT panchromatic data overlaid with an 
environmental sensitivity analysis file.

In creating this map, you use these basic steps:

• plan the map

• start Map Composer

• prepare the data layers

• draw the map frame

• add a neatline and tick marks

• make scale bars

• create a legend

• add a map title

• place a north arrow

• write descriptive text

• print the map

This tour guide also contains information about editing map frames, 
deleting map frames, and editing map compositions.
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Start Map Composer You must have ERDAS IMAGINE running.

1. Start Map Composer by clicking the Composer icon  on the ERDAS 
IMAGINE icon panel.

The Map Composer menu displays.

2. In the Map Composer menu, select New Map Composition to 
create a new map composition.

You can also create a new composition by selecting File -> New 
-> Composition from the Viewer menu bar.

The New Map Composition dialog opens.

3. In the New Map Composition dialog under New Name, type a unique 
name for your map (such as tour.map). Be sure that you have write 
permission in the directory where you are creating the new map.

4. Drag across the value in Map Width to select it.

Click here to
create a new map

Specify map 

Click here

Type a name

size here
in meters
or in inches

for your map
here

 to make
a new map
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5. Type 7.5 and then press the Enter key on your keyboard.

6. Drag across the value in Map Height to select it.

7. Type 10.0 and then press the Enter key on your keyboard.

Most printers have a small margin on all sides of a sheet that are 
unprintable. Therefore, even though you output your map to 8.5” × 
11.0” paper, you must specify a smaller size here for the actual live 
area of the map. This ensures that no part of the map occupies that 
unprintable area, and it leaves a margin around the edge of the 
composition.

8. Accept the Display Scale 1 of 1.00 and inches for the Units.

9. Click OK in the New Map Composition dialog.

A blank Map Composer viewer displays along with the Annotation 
tool palette. 

NOTE: The tool palette that displays on your screen may look 
different from the following one, depending upon your ERDAS 
IMAGINE preferences. 

10. With your cursor in the Map Composer viewer, right-hold Fit Map To 
Window from the Quick View menu so that you can see the entire 
map composition page.

Menu bar 

Toolbar 

Compose 
map here 

Annotation tool palette

Title bar 

Status bar 
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Prepare the Data 
Layers

You must determine what data layer(s) you are going to use in your 
composition and then display the layer(s) in a Viewer window. In this 
exercise, you use modeler_output.img from the 
<ERDAS_Data_Home>/examples directory. 

ERDAS IMAGINE must be running, and you must have a Viewer and 
a Map Composer viewer open.

1. In the Viewer, click the Open icon  on the toolbar or select File -
> Open -> Raster Layer from the menu bar. 

The Select Layer To Add dialog opens.

2. In the Select Layer To Add dialog under Filename, click 
modeler_output.img. Be sure that the source directory is 
<ERDAS_Data_Home/examples> (the default).

3. Click the Raster Options tab and then select the Fit to Frame 
option so that you can see the entire file and can more easily select 
the area to include in the map. 

4. Click OK in the Select Layer To Add dialog.

Draw the Map 
Frame

You can now begin creating your map composition. The first step in 
creating your map is to define the map frame. 

Second, click here to
display the Raster Options

A preview
of the image
displays
here

The file type
should be
.img

First, click 
here to 
select the file
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A Viewer must be open, with the data layer you want to use in your 
composition displayed in it. You must also have an open Map 
Composer viewer.

1. From the Annotation tool palette, click the Map Frame icon  to 
draw the boundary of the map frame.

2. Near the top of the Map Composer viewer, Shift-drag your cursor 
downward at an angle to draw the map frame. You position and size 
the map frame later. 

NOTE: Pressing the Shift key while drawing the map frame allows 
you to draw a perfect square.

When the mouse is released, the Map Frame Data Source dialog 
opens.

What is a Map Frame?
A map frame is drawn, resized, and selected like other annotation 
elements, but a map frame works like a Viewer. Map frames can 
contain raster, vector, and annotation layers that you want to 
include in your composition. 

Although map frames display the layer(s) you want to include in a 
map composition, the data in a map frame are not copied, but are 
referenced. When you create a map frame, simply click in the 
Viewer where the layers you want to use in the map are displayed.

Map Frame Dimensions
There are three ways to select the dimensions of a map frame. You 
use different options depending on the image area you want in the 
final map composition. The dimensions of a map frame are 
expressed in the following ways:

• The map area is the area in the Viewer that displays in the map 
frame in the map composition. It corresponds to the 
dimensions of the area on the ground in map units.

• The frame area is the area used by the map frame in the map 
composition. It is the area on the page occupied by a particular 
image. It is defined in page units.

• The scale (like the scale used in geometric correction) is the 
ratio of distance in the map frame to the distance that is 
represented on the ground. For example, you can define an 
area showing a scale of 1:24,000.
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3. In the Map Frame Data Source dialog, click the Viewer button to 
select the source image from the Viewer.

The Create Frame Instructions dialog displays.

4. Click anywhere in the image in the Viewer to reference the displayed 
image to the new map frame.

The Map Frame dialog opens, giving you options for sizing, scaling, 
and positioning the map frame. 

A cursor box also displays in the Viewer. This cursor box allows you 
to select the area you want to use in the map composition.

Click here to enter
map frame height
and width in inches

Click here to enter
map frame X
and Y coordinates

Click here to adjust
the position of the 

Click here to enter
the scale of the data 
in the map frame

map frame

Click here to adjust
the size of the map
frame
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Adjust the Size of the Map 
Frame

1. In the Map Frame dialog, click the Change Map and Frame Area 
(Maintain Scale) option so that you can accurately size the map 
frame in the Map Composer viewer window.

2. In the Map Frame dialog, double-click the value in Frame Width to 
select it.

3. Type 5.5 for the width of the map frame and then press the Enter 
key on your keyboard.

Moving and Adjusting the Map Frame
You can move the map frame in the Map Composer viewer window 
and the cursor box in the Viewer by dragging and resizing them 
with the mouse, or you can move one or both boxes by 
manipulating the information in the Map Frame dialog. You can 
also rotate the box in the Viewer if you want to change the 
orientation. 

Next, you move the map frame by setting parameters in the Map 
Frame dialog. Then you can select the image area you like by using 
the mouse to move the cursor box in the Viewer.

The three buttons at the top of the Map Frame dialog allow you to 
adjust two parameters while keeping the other frozen. Start by 
selecting the size of the map frame (Change Scale and Frame 
Area), and then freeze that option to select the scale and position 
of the map frame (Change Scale and Map Area).

Your map frame is positioned according to the following 
illustration:

NOTE: The origin of the Map Composer viewer is the lower left 
corner.

5.5” x 5.5”

10”9.0” (Y) 

1.0” (X)

3.5”

1
.0

”
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4. Double-click the value in the frame Height (to the right of Frame 
Width) to select it.

5. Type 5.5 for the height of the map frame and then press the Enter 
key on your keyboard.

Adjust the Position of the 
Map Frame

1. In the Map Frame dialog, click the Change Scale and Map Area 
(Maintain Frame Area) option so that you can select a map area 
in the Viewer without losing the dimensions of the map frame in the 
Map Composer viewer.

2. In the Map Frame dialog, under Upper Left Frame Coordinates, 
change the Y value to 9.0. Press Enter on your keyboard.

3. Double-click the value in Scale 1 to select it. Type 50000. Press 
Enter on your keyboard.

4. With your cursor inside the cursor box in the Viewer, drag the cursor 
box to the area you want to display in the map composition.

5. When the cursor box is positioned to your satisfaction, click OK in 
the Map Frame dialog to reference that portion of the image to the 
map composition.

The image area that you selected in the Viewer is now displayed in 
the map frame in the Map Composer viewer. 

6. To enlarge the image in the Map Composer viewer, drag on the 
corners of the Map Composer viewer to enlarge it, and the right-hold 
to select Fit Map To Window from the Quick View menu.
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7. You are now finished with the Viewer, so select File -> Close from 
the Viewer menu bar to close it.

Choose Your Path

• If you are satisfied with your map frame and the image area you 
have selected, proceed to “Add a Neatline and Tick Marks”.

• If you want to edit your map frame or change the image area you 
selected, proceed to “Edit the Map Frame”.

Edit the Map 
Frame

The Map Composer is very flexible in allowing you to place a map 
frame in a composition based on scale, image area, etc. Once you 
have placed a map frame in a composition, you can move it, change 
the size of it, and change the image area within it. 

If you want to change the image you are using, you must delete 
the map frame and redraw it or edit the .map file.

Choose Your Path • To edit the map frame, proceed with this section.

• To delete the map frame, proceed to “Delete the Map Frame”.

• To edit the .map file, proceed to “Edit Composition Paths”.
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1. To edit a map frame, click the Select Map Frame icon  in the 
Annotation tool palette.

2. Click in the map frame you want to edit to select it.

3. In the Map Composer viewer, select Annotation -> Element 
Properties or double-click in the map frame.

A new Viewer opens, with the image you are using displayed. A white 
cursor box indicates the area currently in the map frame. The Map 
Frame dialog also opens, displaying the settings you originally 
entered to position and size the map frame. 

4. Change the information in the Map Frame dialog and/or move the 
cursor box in the Viewer.

5. Click OK in the Map Frame dialog when you are satisfied with the 
map frame.

6. Select File -> Close from the Viewer menu bar.

Delete the Map 
Frame

If you want to delete the map frame altogether, follow the next 
series of steps.

Deleting a map frame cannot be undone.

You must have your map composition open.

1. In the Map Composer viewer menu bar, select View -> Arrange 
Layers.

The Arrange Layers dialog opens. 

2. In the Arrange Layers dialog, move your pointer to the box titled 
MapFrame__modeler_output.img and right-hold to select 
Delete Layer from the Frame Options dropdown list. 

Press the third mouse
button to delete
this map frame

Click here to delete
the map frame
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3. In the Arrange Layers dialog, click Apply to delete the map frame. 

4. Click Close in the Arrange Layers dialog.

You are now ready to redraw the map frame. Return to “Draw the 
Map Frame”.

Add a Neatline 
and Tick Marks

Now, add a neatline and labeled tick marks around the image in the 
map composition.

You must have a Map Composer viewer open containing a map frame 
referenced to a georeferenced image in order to generate 
georeferenced tick marks. The Annotation tool palette must also be 
open.

1. If you have not already done so, right-hold Fit Map To Window in 
the Map Composer viewer so that you can see the entire map 
composition page.

2. Click the Grid/Tick icon  on the Annotation tool palette.

3. Click the image inside the map frame on which you want to place the 
neatline and tick marks.

The Set Grid/Tick Info dialog opens.

Neatlines and Tick Marks

• A neatline is a rectangular border around a map frame.

• Tick marks are small lines along the edge of the map frame or 
neatline that indicate regular intervals of distance. Tick marks 
are usually labeled in meters, feet, or other units.

The Map Composer allows you to generate a neatline and labeled 
tick marks at the same time. A set of these elements for a map 
frame is actually a group of line and text elements that is 
automatically generated to your specifications. (You can also 
generate grid lines in the same step, but grid lines are not included 
in this map.)
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4. Accept the default of Neat line to put a neatline around the map and 
leave the Margin at 0 so that the neatline fits to the edge of the map 
frame.

5. In the Horizontal Axis options, drag across the Length Outside 
field to select it.

6. Type a tick length of 0.06. Press Enter on your keyboard.

Tick marks extend 0.06” outside of the map frame.

7. Drag across the Spacing field to select it.

8. Type 5000. Press Enter on your keyboard.

The Number of lines is about 4, indicating that there are 4 
horizontal tick marks (depending on the actual image area you 
selected).

9. Click the Copy to Vertical option to apply these settings to the 
vertical axis.

The same settings are applied to the vertical axis. 

10. Click the Vertical Axis tab to verify neatline and label information 
for the vertical axis.

11. Click Apply in the Set Grid/Tick Info dialog to place the neatline and 
tick marks on the map. 

12. If you are satisfied with the appearance of the neatline, click Close 
in the Set Grid/Tick Info dialog. Otherwise, you may make 
adjustments in the Set Grid/Tick Info dialog and click Redo to apply 
them. Your map should look similar to the following: 

Specify neatline 

Enter tick mark
information here
for the horizontal

Click here to 
copy horizontal 
tick information to
the vertical axis

axis

here
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Change Text/Line Styles The text and line styles used for neatlines, tick marks, and grid lines 
depend on the default settings in the Styles dialog. You can either 
set the styles before adding this annotation to your map, or you can 
change the styles once they are placed in the map. 

Next, set the line style to 1 point for the neatline and tick marks, and 
the text size to 10 points for the tick labels.

1. Select the group of ticks, tick labels, and the neatline by clicking on 
any of the number labels outside of the map frame. 

A selection box displays around the entire group.

2. From the Map Composer viewer menu bar, select Annotation -> 
Styles.

The Styles dialog opens.

Hold on this dropdown
list to select Other
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3. In the Styles dialog, hold on the dropdown list next to Line Style and 
select Other.

The Line Style Chooser dialog opens.

4. In the Line Style Chooser dialog next to Width, enter 1.00 to change 
the width in points.

5. Click Apply and then Close in the Line Style Chooser dialog.

The group redraws with the new line width.

6. In the Styles dialog, hold on the dropdown list next to Text Style 
and select Other.

The Text Style Chooser dialog opens.

7. In the Text Style Chooser dialog, verify that the Size is 10.00.

8. Click Apply and then Close in the Text Style Chooser dialog.

9. Deselect this annotation group by clicking anywhere in the map 
composition window outside of the selection box.

10. Click Close in the Styles dialog.

Change the 
line width 
here

Verify that the
text size is 10
points
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Make Scale Bars A scale bar indicates the scale of the image on the map. You can 
create one scale bar, or several, showing the scale in different units. 
A scale bar is actually a group of elements that is automatically 
generated to your specifications. 

In this section, place two scale bars in your map composition, 
showing scale in kilometers and miles. Then center them under the 
map frame. 

You can create scale bars only for map frames containing 
georeferenced data.

You must have a map composition open and it must contain 
georeferenced data. The Annotation tool palette must also be open.

1. To place scale bars, select the Scale Bar tool  from the Annotation 
tool palette.

2. Move the cursor into the Map Composer viewer and the cursor 
changes to the scale bar positioning cursor. 

3. Drag the mouse to draw a box under the right corner of the map 
frame in the Map Composer viewer, outlining the length and location 
of the scale bar(s).

You can change the size (length) and location later, if needed. 

When you release the mouse button, the Scale Bar Instructions 
dialog is activated. 

4. Follow the instructions in the Scale Bar Instructions dialog by clicking 
in the map frame to indicate that this is the image’s scale you are 
showing. 

The Scale Bar Properties dialog opens.
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5. In the Scale Bar Properties dialog under Units, select Kilometers 
and Miles by clicking the appropriate checkboxes.

6. Set the Maximum Length to 2.0 inches. Press Enter on your 
keyboard.

7. Click Apply in the Scale Bar Properties dialog. 

The scale bars display where you drew the box in the Map Composer 
viewer.

8. If you are satisfied with the appearance of the scale bar, click Close 
in the Scale Bar Properties dialog. Otherwise, you may make 
adjustments in the Scale Bar Properties dialog and click Redo to 
apply them.

Reposition Scale Bars

1. If you need to move the scale bars, first select them by clicking on 
one of the scale bars. To move, simply drag the selection box to the 
desired position. Remember to click outside the selection box to 
deselect the scale bars.

Create a Legend A legend is a key to the colors that are used in a map. Legends 
created in the Map Composer are actually groups of elements that 
are generated automatically to your specifications. 

Next, you create a legend explaining the four colors used in the 
overlaid environmental sensitivity analysis.

You must have a map composition open that contains thematic data. 
The Annotation tool palette should also be open.

1. Click the Legend icon  in the Annotation tool palette.

2. Move the cursor into the Map Composer viewer and the cursor 
changes to the legend positioning cursor. 

Click here to
center scale bars
on each other

Click here
and here
to select units

Select length of
scale bars here
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3. Click in the Map Composer viewer under the left side of the map 
frame to indicate the position of the upper left corner of the legend.

4. Click in the map frame to indicate that this is the image you want to 
use to create the legend. You are reminded to do this with the 
following dialog: 

The Legend Properties dialog opens, with the Basic properties 
displayed. The class names are listed under Legend Layout.

5. Under Legend Layout, click in the Class_Names field (entitled 
Class_5) of Row number 6.

6. Type SPOT Panchromatic. Press Enter on your keyboard.

7. Under Legend Layout, move your cursor to the Row column and 
click Row 2, then middle-click Row 6 to select the classes to display 
in the legend. 

Rows 2 and 6, and the rows in between them are highlighted in 
yellow. These are the only entries that are used in the legend.

8. In the Legend Properties dialog, click the Title tab at the top of the 
dialog.

Middle-click here
to select multiple
rows

Click here to 
change the class 
name to SPOT 

Click here for 
title properties 

Panchromatic
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9. Click the Title Alignment dropdown list and select Left-Justified.

10. In the Legend Properties dialog, click Apply.

The legend is drawn in the Map Composer viewer.

11. If you are not satisfied with the appearance of your legend, you may 
make adjustments in the Legend Properties dialog and click Apply 
or Redo to apply them. 

12. Click Close in the Legend Properties dialog when finished.

Reposition Legend

1. If you wish to reposition the legend, click any of the color patches or 
text strings in the legend to select it. To move, hold and drag the 
selection box to the desired position. Remember to click outside the 
selection box to deselect the legend.

Add a Map Title You must have a map composition and the Annotation tool palette 
open.

1. Click the Text icon  in the Annotation tool palette.

2. Move your cursor to the top of the map in the Map Composer viewer. 

The cursor becomes an I-beam , indicating that you are placing 
text.

3. Click where you want to place the text. The spot where you click is 
the bottom left corner of your text string.

The Annotation Text dialog opens.

Click this tab 
to view title 
properties 

Click this 
dropdown list to 
specify alignment 
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4. Move your pointer into the Enter Text String area in the Annotation 
Text dialog.

5. Type Environmental Sensitivity Analysis in the text field. 

6. Click OK in the Annotation Text dialog to place the text in the map 
composition.

The text string is now displayed in the map composition.

Change Text Style

1. Click the text string in the Map Composer viewer to select it.

2. From the Map Composer menu bar, select Annotation -> Styles.

The Styles dialog opens.

3. In the Styles dialog, hold on the dropdown list next to Text Style 
and select Other.

The Text Style Chooser dialog opens.

4. In the Text Style Chooser dialog, change the text Size to 20 points.

The preview window at the bottom right corner of the Text Style 
Chooser dialog illustrates the change in point size.

5. In the Text Style Chooser dialog, click the Custom tab.

6. In the scrolling list of font names, scroll to the top of the list and 
select Antique-Olive. The preview window at the bottom right 
corner of the dialog illustrates the selected font.

7. Click Apply in the Text Style Chooser dialog to change the selected 
text in the map composition.

8. Click Close in the Text Style Chooser dialog if you are satisfied with 
your changes.

Position Text

1. Double-click the text string you just edited. The Text Properties 
dialog opens, which allows you to edit, position, and align the text.

Type text 
string here
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2. In the Text Properties dialog, under Position, drag across the X 
value to select it.

3. Type 7.5/2 to calculate the center of the map. Press Enter. The 
value 3.75 is returned.

4. Change the Y value to 9.5 and press Enter on the keyboard.

5. Under Alignment, the Vertical default should be Bottom. Click the 
Center radio button under Horizontal. This indicates that position 
3.75 × 9.5 (that you just entered) is to be the bottom center of the 
text string.

6. Click Apply in the Text Properties dialog to center the text.

7. Click Close in the Text Properties dialog.

8. Deselect the text by clicking elsewhere in the background of the Map 
Composer viewer.

Place a North 
Arrow

Map Composer contains many symbols, including north arrows. 
These symbols are predrawn groups of elements that are stored in a 
library. Other symbols include school, church, marsh, landmark, and 
many others.

You must have a map composition and the Annotation tool palette 
open.

1. If the Styles dialog is not currently open, select Annotation -> 
Styles from the Map Composer menu bar.

The Styles dialog opens.

Enter text 
string X,Y 

Edit text 
string here

position here

Specify 
horizontal
and vertical
alignment
here
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2. In the Styles dialog, hold the dropdown list next to Symbol Style 
and select Other.

The Symbol Chooser dialog opens.

3. In the Symbol Chooser dialog, click the dropdown list and select 
North Arrows.

4. Select north arrow 4 from the North Arrows list.

The preview window at the bottom right corner of the Symbol 
Chooser dialog displays north arrow 4.

5. In the Symbol Chooser dialog, change the Size to 36 points (a size 
of 72 points is equal to one inch), and press Enter on the keyboard.

The preview window at the bottom right corner of the Symbol 
Chooser dialog displays the north arrow as it looks in the map 
composition. 

6. Click Apply and then Close in the Symbol Chooser dialog to make 
this the default symbol.

Note that the North Arrow is now the default symbol for Symbol 
Style in the Styles dialog.

7. Select the Symbol tool  from the Annotation tool palette.

8. In the Map Composer viewer, click under the map image, between 
the legend and the scale bars.

The north arrow is placed on your composition. You can reposition it 
by clicking on it to select it, then dragging it to the new position.

Hold on this
dropdown list to 
select Other 

Click here to 
select from a 
list of north
arrows

Select this 
north arrow 

Change the 
size here 
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You can also double-click a selected symbol to bring up the Symbol 
Properties dialog. Here, you can enter size and positioning 
measurements.

Write Descriptive 
Text

You can add descriptive text to your map to provide more 
information. The steps below include the instructions for adding two 
lines of text. However, you may add more if you like.

You must have a map composition and the Annotation tool palette 
open. 

1. If the Styles dialog is not currently open, select Annotation -> 
Styles from the Map Composer menu bar.

The Styles dialog opens.

2. In the Styles dialog, hold on the Text Style dropdown list and select 
Other.

The Text Style Chooser dialog opens.

3. In the Text Style Chooser dialog, change the text Size to 10 points. 

4. Click the Custom tab at the top of the Text Style Chooser dialog.

5. Check to be sure that Fill Style is set to solid black.

6. Click Apply to change the defaults.

7. Click Close in the Text Style Chooser dialog and in the Styles dialog.

Place Text

1. Click the Text icon  in the Annotation tool palette to use the text 
option to write descriptive text.

2. Click in the bottom right side of the map composition to indicate 
where you want to place the text.

The Annotation Text dialog opens.

3. Move your pointer into the Annotation Text dialog and type the 
following lines under Enter Text String. At the end of the first line, 
press Enter to left-align the text.

San Diego, California<return>
Environmental Sensitivity Analysis

You may click the ASCII File button to import the text from an 
existing ASCII text file.

4. Click OK in the Annotation Text dialog to place the text.

The Annotation Text dialog automatically closes.
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Save the Map 
Composition

1. Save your map composition by clicking the Save icon  in the Map 
Composer toolbar.

You can also save a composition by selecting File -> Save -> 
Map Composition from the Map Composer menu bar.

Print the Map 
Composition

ERDAS IMAGINE supports many output devices, including 
electrostatic plotters, continuous tone color printers, and PostScript 
devices. The printers you can use vary depending on your system 
configuration. These steps illustrate how to print to a PostScript 
printer.

1. Click the Composer icon from the ERDAS IMAGINE icon panel. 

The Map Composer menu displays.

2. Select Print Map Composition from the Map Composer menu, or 
select File -> Print from the Map Composer viewer menu bar.

The Compositions dialog opens.

3. Under Filename, click the name of the map you previously created.

4. Click OK in the Compositions dialog.

The Print Map Composition dialog opens.

Click the 
map name 

Click here to 
print the map 

here 
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5. Click the Print Destination dropdown list to select the printer you 
want to use.

If you do not have any output devices configured, you can output 
your map to an ERDAS IMAGINE image file (.img extension), and 
display it in a Viewer. When displaying maps converted to image 
format, assign bands 1, 2, 3 to R, G, B, respectively, in the Select 
Layer To Add dialog. This gives you an idea of what the map looks 
like if it is printed.

6. For this exercise, select EPS File in the Print Destination 
dropdown list to create an encapsulated PostScript file. This file can 
be sent to a PostScript printer using the standard file print command 
for your platform.

7. Click OK to print the map composition.

Edit Composition 
Paths

This section describes how to edit a map composition when you want 
to use another image in an existing map frame, or if the original 
image you used has been moved to another directory.

Select printer
destination here 

Click here to
print the map 
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You must have a saved map composition (.map file).

1. Click the Composer icon on the ERDAS IMAGINE icon panel.

The Map Composer menu displays.

2. In the Map Composer menu, select Edit Composition Paths.

The Map Path Editor displays.

3. In the Map Path Editor, select File -> Open or click the Open icon 

 . 

The Compositions dialog opens.

.map File
When you create a map or a graphic using Map Composer, a file is 
created with the .map extension. This file contains all of the 
specifications for your composition, such as size, position of the 
image, name of the image, annotation, etc. When you display or 
print a map composition, the software reads this .map file and 
recreates the map you originally composed. 

So, although you place an image in a composition, you are actually 
only referencing it. The name of the image you are using is listed 
in the .map file. Therefore, when that image is enhanced or 
changed in any way, the image in the map composition also 
changes because it is the same image.

It is necessary to edit a .map file if you wish to move an image that 
has been used in a map composition to a new directory. 

Editing Annotation
The annotation in a map composition can be edited interactively 
with the Annotation tools in the Annotation tool palette, using the 
same methods you used to place the annotation when you 
originally created the map. 

Click here to
edit the composition
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4. In the Compositions dialog under Filename, select the map file you 
wish to edit (for example, tour.map).

5. Click OK in the Compositions dialog.

The information for the selected map file displays in the Map Path 
Editor.

6. In the Map Path Editor under Frame, click 
MapFrame_modeler_output.img.

The type of Layer and Layer Information displays for the image. 
Note the path name for this image (located under Layer 
Information in the Name section).

7. Under Frame, click Composition.

8. Under Layer Information, type the new file name or directory 
name in the Name text entry field.

9. Click Apply in the Map Path Editor.

The changes you made are applied to the map composition.

After you make each individual edit to each frame or layer, you 
must click Apply.

10. If you do not want the changes you have just made, click the Reset 
button.

11. When you are satisfied with your changes, save the file by selecting 
File -> Save from the Map Path Editor menu bar.

For more information about cartography, see the chapter 
“Cartography” in the ERDAS Field Guide.
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Import/Export

Introduction The ERDAS IMAGINE Import function allows you to import a wide 
variety of data types for use in ERDAS IMAGINE. The Export function 
lets you convert image (ERDAS IMAGINE .img file format) files into 
one of several data formats.

In this tour guide, you can learn how to:

• import SPOT data from CD

• import ERDAS 7.x GIS and Generic Binary Data files

• export an image file in the ERDAS 7.x LAN format

• create a TIFF file 

• view raw data values using the Data View option

• view image data information using the ImageInfo utility

Approximate completion time for this tour guide varies 
depending upon the data you are importing or exporting.

Import a SPOT 
Scene

Before you can import data from a peripheral device, such as a tape 
drive or a CD-ROM drive, you may configure the device in ERDAS 
IMAGINE. 

Select Session -> Configuration... from the ERDAS IMAGINE 
icon panel to configure devices.

This section takes you through the steps to import SPOT data. 
Since each individual has different types of SPOT data, these 
steps are only an example. 

1. If your Session Log is not already open, select Session -> Session 
Log from the ERDAS IMAGINE menu bar. 

The Session Log displays real-time messages about what is 
happening throughout the import process. Following these messages 
closely helps you understand what is happening.

2. Click the Import icon on the ERDAS IMAGINE icon panel.
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The Import/Export dialog opens:

The Import button is enabled when the dialog first opens, so that all 
of the prompts that display in the dialog are for importing data. 
When you click the Export button, the prompts change to options 
for exporting data. 

3. Click the Type dropdown list to select SPOT from the list of available 
importers. 

4. Confirm that the Media defaults to CD ROM. 

5. Displayed under Input CDROM is a list of configured CD-ROM 
drives. Click to select the device from which you want to import data. 

If it is necessary to configure a new device, select Session -> 
Configuration... from the ERDAS IMAGINE icon panel.

6. Under Output File, enter a name for the output file in the directory 
of your choice. You can click the directory bar dropdown list or enter 
the directory name in the file name part to select a different 
directory.

7. Click OK in the Import/Export dialog. 

8. Watch the Session Log to see a report of the activities of the import 
process. 

The Import SPOT dialog opens:

Select Import
or Export here

Click here to
see a list of data
types

Click here
to select media

Click here to
file name part: 

Default file 
extension is 
shown in

Click to see
the raw data values
of the input file

parentheses

select configured
Enter the outputinput device

Directory bar: 
Click this
dropdown list to
change directories 

 
directory and file
name here
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Check Preview Options

1. Click Preview Options and the following dialog opens:

Shows information about 
the selected image 

Shows map projection 
information, if available 

Click to go to the previous 

multi-image CD 

Click to go to the next 

multi-image CD
image on CD, if a 

image on CD, if a 

Click here to see 
a preview image before 
importing the data 

Click here to define 
options for the preview 
image 
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2. Click OK in the Preview Options dialog. 

3. Click Preview in the Import SPOT dialog. 

A Job Status dialog displays, indicating the progress of the function.

When the Job Status bar shows 100 (indicating that the job is 100% 
done), the dialog automatically closes. A Viewer window similar to 
the following opens and displays the preview image:

Preview Options Dialog
The Preview Options allow you to import a decimated (that is, 
reduced) version of the image file. You can view the image before 
importing to be sure that this is the image you want, or to define 
a subset area of the image to import.

The Preview Options dialog is the same for all importers. For 
example, if you were importing a Landsat TM scene and you 
wanted to preview the image, the Preview Options dialog would be 
identical to the one in “Check Preview Options”. 

In the Preview Options dialog, you can set:

• Size of the displayed image—up to 512 × 512 or 1024 × 1024.

• Decimation—Nearest Neighbor (provides a faster preview 
image, although it may appear blocky) or Average Pixel 
(averages groups of pixels, which provides a smooth image but 
may take longer, especially with large images).

• Preview Bands—the bands that are assigned the red, green, 
and blue colors in the previewed image (this option may not be 
applicable to some data).

• Coordinate Type—the type of coordinates used to define the 
subset. If there is no map information in the source image, 
only File coordinates are available.

• Subset Definition—define a subset area for previewing or 
importing. 
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Preview images have a .preview.img file extension. Because 
the preview image is decimated, it is not suitable for image 
processing.

Check Import Options

1. In the Import SPOT dialog, click Import Options.

The Import Options dialog opens. This dialog is similar to the Preview 
Options dialog.

NOTE: Like the Preview Options dialog, the Import Options dialog is 
the same for every type of importer.

2. Select Utility -> Inquire Box from the SPOT_test.preview.img 
Viewer menu bar. 
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The Inquire Box Coordinates dialog opens and a rectangular box (the 
Inquire Box) displays in the center of the Viewer. 

3. When you have selected the subset area to import, click From 
Inquire Box in the Import Options dialog. 

The coordinates for the subset area display in the Import Options 
dialog. 

Sometimes, when map coordinate information is not available in 
the source image, there are apparent differences between the 
Inquire Box coordinates and those transferred to the Import 
Options dialog. However, the imported image subset matches 
the area bounded by the inquire box.

4. Click OK in the Import Options dialog.

5. Click OK in the Import SPOT dialog.

A Job Status dialog displays, indicating the progress of the import 
process:

Depending on your eml Preferences, when the Job Status bar 
shows 100 (indicating that the job is 100% done), you must either 
click OK to close the dialog or the dialog closes automatically.

6. Open a Viewer window and display the output file.

Subset an Area
You can select a subset area to be imported by moving and 
resizing the Inquire Box in the Viewer:

• to resize the Inquire Box, hold and drag on the sides or corners 
of the box

• to move the Inquire Box, hold and drag in the center of the box

The coordinates update in the Inquire Box dialog as you move 
and/or resize the Inquire Box.
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See the chapter "Raster and Vector Data Sources" in the ERDAS 
Field Guide for more information on importing data.

Export LAN Data In this section, you export one of the image example files to an 
ERDAS Version 7.x LAN file. 

Choose Export Options ERDAS IMAGINE should be running and the Import/Export dialog 
should be open.

1. In the Import/Export dialog, click Export. 

2. Click the Type dropdown list to see a list of available exporters.

3. Click to select LAN (Erdas 7.x) from the Type dropdown list.

4. Confirm that the Media lists File. 

5. Enter lanier.img under Input File. 

6. In the Import/Export dialog, ERDAS IMAGINE automatically enters 
lanier.lan as the output file. You may change this name if you want.
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7. Click OK in the Import/Export dialog.

The Export ERDAS 7.5 LAN Data dialog opens:

8. Click OK in the Export ERDAS 7.5 LAN Data dialog. 

A Job Status dialog displays. 

The file lanier.lan now resides in the selected directory. 

Creating LAN Data
ERDAS IMAGINE also creates two other files when it exports the 
LAN data:

• lanier.pro—contains map projection information

• lanier.sta—contains file statistics

These file formats are used in ERDAS 7.5 software. In ERDAS 
IMAGINE, map projection and file statistics are included in the 
image file format. You may delete the files lanier.pro and 
lanier.sta if desired, since they are not used in this exercise. 
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Create .tif Files In this section, run an ERDAS IMAGINE process, producing a .tif file 
instead of an image file. 

NOTE: Since the input image is georeferenced, the output TIFF 
image has geotiff tags. If you wish to produce a TIFF World file, 
select the Write option in the TIFF image file category of the 
Preference Editor.

1. Click the Classifier icon on the ERDAS IMAGINE icon panel. 

The Classification menu opens.

2. Click Unsupervised Classification from the Classification menu. 

The Unsupervised Classification (Isodata) dialog opens.

Click here to start the
Unsupervised Classification
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3. Click the Open icon  by Input Raster File.

The Input Raster File dialog opens.

4. In the Input Raster File dialog, click dmtm.img, then click OK.

The raster file, dmtm.img, is located in the 
<ERDAS_Data_Home>/examples directory.

5. Click the Open icon next to Output Cluster Layer Filename.

The Filename dialog opens.

6. Navigate to a directory where you have write permission.

7. Click the File Type dropdown list, and select TIFF (*.tif). 

8. Type in dmtm1.tif in the Filename field, and then click OK.

9. Change the Number of Classes to 30. This tells the classifier how 
many classes to create. 

10. Deselect the Output Signature Set Filename checkbox. 

11. Click OK at the bottom of the Unsupervised Classification dialog. 

A job status dialog displays the progress of the classification of the 
file.

Select the input file here

Name the output file here

Uncheck the Output Signature 
Set Filename checkbox

Change the number of 
classes to 30
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The resulting classification is created in the .tif format.

Check the Classification

1. Click the Viewer icon to open a Viewer.

2. From the Viewer toolbar, click the Open icon  .

3. In the Select Layer To Add dialog, click the Recent button.

4. Select the file dmtm1.tif from the top of the list.

5. Click OK in the List of Recent Files dialog.

6. Click the Raster Options tab of the Select Layer to Add dialog.

Select dmtm1.tif from the top 
of the Recent Files list

Select Gray 

Select Fit to 

Scale

Frame
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7. Click the Display as dropdown list and select Gray Scale.

8. Click the Fit to Frame checkbox.

9. Click OK in the Select Layer To Add dialog.

The file dmtm1.tif displays in the Viewer. The various shades of 
gray denote different classes of land cover.

Check Map Information

1. Click the ImageInfo icon  on the Viewer toolbar.

The ImageInfo dialog for dmtm1.tif opens.
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Note the information in the Map Info section and that the 
Projection Info section shows that the map is georeferenced to 
State Plane.

2. When you are finished, click File -> Close in the ImageInfo dialog.

3. Click File -> Close in the Viewer containing dmtm1.tif.

Import Generic 
Binary Data

In this section, you import the lanier.lan file that you just exported. 
This file could be imported using the ERDAS 7.x LAN import function. 
However, you are using this file to learn how the Generic Binary Data 
dialog works. 

This function is designed for importing data types for which there are 
currently no specific ERDAS IMAGINE importers. 

1. In the Import/Export dialog, click Import.

2. Click the Type dropdown list and select Generic Binary.

3. Select File from the Media dropdown list.

4. Under Input File, select lanier.lan. Change directories if needed by 
clicking on the directory bar. 

Note map and 
projection 
information
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5. Under Output File, ERDAS IMAGINE automatically enters 
lanier.img as the file name. If you try to save the file in the 
<ERDAS_Data_Home>/examples directory, an Attention message 
warns you that lanier.img already exists.

6. If the Attention dialog displays, click No. 

This prevents the original lanier.img file from being overwritten. 

7. In the Import/Export dialog, enter lanier2.img as the Output File 
in the directory of your choice. 

8. In the Import/Export dialog, click OK. 

The Import Generic Binary Data dialog opens.

This dialog requires you make many inputs that define the data 
structure for ERDAS IMAGINE. In some cases, you can get the 
information for these inputs from the header data of the file (using 
the Data View option from the Import/Export dialog), but you may 
have to rely on prior knowledge or assumption for the information. 

You must enter the correct inputs for the data you are importing. 
The defaults for this dialog are not acceptable for importing. 

Data View

1. Click the Data View button in the Import/Export dialog. 

The DataView dialog opens. The data, as initially displayed, may not 
appear to be very useful. The following steps result in a display from 
which you can extract the information needed to complete the 
generic import.

Data View is also available from the Utility menu on the ERDAS 
IMAGINE menu bar.

Click here to
select input file

Directory bar:
Click this
dropdown list to
change directories

Click here to see
raw data values and
header information

ERDAS IMAGINE
automatically
enters this
output file
name with 
.img extension
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2. In the DataView dialog, click Data Type and select Unsigned 16 
bit.

3. In the DataView dialog, click Byte Order and select Intel.

4. Set the Offset to 8 and check that the Format is Decimal.

The DataView dialog is updated to look like the following:

5. In the DataView dialog, click Data Type and select Unsigned 32 
bit.

6. In the DataView dialog, click Byte Order and select Intel.

LAN File Format
The LAN format has the following characteristics:

• the first 128 bytes of the file are header data

• the number of bands is stored as a 16-bit integer in bytes 9 and 
10

• the number of columns is stored as a 32-bit integer in bytes 
17-20

• the number of rows is stored as a 32-bit integer in rows 21-24

With this knowledge, you can look at the data values in these bytes 
to obtain the information needed to import the file as generic 
binary data.

Data field
displays
actual data
values

Number
of bands

Offset equals 8 because
number of bands begins
in byte 9

Unsigned 16 bit data 
selected because
number of bands 
is two bytes
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7. Set the Offset to 16 and check that the Format is Decimal.

The DataView dialog updates. 

Enter Image Dimensions

1. In the Import Generic Binary Data dialog, next to File Header 
Bytes, enter 128.

This is the number of bytes in the header, before the actual data 
values begin.

2. Under Image Dimensions, for # Rows, enter 512.

3. Under Image Dimensions, for # Cols, enter 512.

4. Under Image Dimensions, for # Bands, enter 7.

The Import Generic Binary Data dialog updates.

Number
of columns

Offset equals 16 because
number of columns begins
in byte 17

Unsigned 32-bit 

Number
of rows

data is selected 

number of 
because the

columns and 

four bytes each
rows are
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Save Options

1. Click Save Options.

The Save Options File dialog opens.

This dialog allows you to save the inputs you have entered to a .gen 
file. It can be recalled and loaded into the Import Generic Data dialog 
whenever you are importing data with this structure. This keeps you 
from having to find and enter the necessary inputs again. 

2. Under File name, enter LAN and move the cursor out of the text 
field. 

ERDAS IMAGINE automatically appends the default .gen file 
extension. Use a descriptive name that helps you to recognize the 
type of inputs saved in the file. 

3. Click OK in the Save Options File dialog. 

These inputs are now saved and can be used again, when 
appropriate. 

Click here to 

Enter number 
of header 
 

Enter image 
dimensions 
and number 
of bands here 

bytes here 

see a preview 
of the image 

Enter name for 
the options file 

Click here 
to save file 
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To load the .gen file at a later time, click the Load Options 
button in the Import Generic Binary Data dialog. 

Preview the Image

1. In the Import Generic Binary Data dialog, click Preview. 

A Job Status dialog displays. When the Job Status bar shows 100 
(indicating that the job is 100% done), the dialog closes 
automatically.

A Viewer automatically opens and displays the file 
lanier2.preview.img. The .preview file extension is added to 
indicate that this is a decimated preview file (not suitable for 
processing).

2. Open another Viewer window and display the file lanier.img. 

You see that the two files are similar in appearance. The difference 
in these files is that lanier.img has map projection information and 
lanier2.preview.img does not. This is because when lanier.img 
was exported to a .lan file, the map information was exported to 
lanier.pro, which is a format used in ERDAS 7.5. The map projection 
data in lanier.pro was not imported with the Generic Binary Data 
importer.

However, the imported image does contain statistics (similar to the 
statistics exported to lanier.sta), because statistics are recalculated 
after a raster file is imported.

3. In the ERDAS IMAGINE menu bar, select Session -> Close All 
Viewers. 

Get Image 
Information

The ImageInfo utility is a function that gives you information about 
ERDAS IMAGINE image files. With this function you can access any 
image file and see the:

• date of last modification

• number of Layers

• layer information: Width, Height, Type, Block Width, Block 
Height, Data Type, Compression, and Pyramid Layer status for 
each layer in the file 

• calculated statistics

• map coordinates, when available

• map projection information, when available

NOTE: ImageInfo can only be used for image files. Use Vector 
Info for vector coverages.
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Edit Image Information In image files that have write permission, you can edit file 
information or perform the following operations using the ImageInfo 
dialog:

• change layer name

• compute statistics

• add, change, or delete map information

• add, change, or delete map projection

• delete calibration

• access the Raster Attribute Editor to change file attributes, such 
as color, histogram values, etc.

View Image Information In this section, you use the ImageInfo utility to learn more about the 
lanier.img file. 

1. Select Tools -> Image Information from the ERDAS IMAGINE 
menu bar. 

The ImageInfo dialog opens.

This option is also accessible from Session -> Tools -> Image 
Information on the ERDAS IMAGINE menu bar.

2. Select File -> Open from the ImageInfo menu bar, or click the Open 

icon  on the toolbar. 

The Image Files dialog opens. This dialog allows you to select a file 
for which information displays in the ImageInfo dialog. 

3. Under Filename, select lanier.img.

Select 
lanier.img
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4. Click OK in the Image Files dialog. 

The information for lanier.img displays in the ImageInfo dialog.

5. Look over the information listed in the dialog. 

The functions in the ImageInfo menu bar in the toolbar are 
described in the On-Line Help.

Since this is a write-protected file, none of these values can be 
changed. If you want to practice editing image information with this 
dialog, you can copy lanier.img to the directory of your choice and 
change the write protections. Then open the writable file in the 
ImageInfo dialog and click Edit to use the editing functions. 

6. Select File -> Close from the ImageInfo menu bar when you have 
read the information in the dialog. 

Menu bar 

Toolbar 

Status bar displays 
single-line help 

Click this dropdown 
list to select the 
layer for which to 
display info 

Map and Projection
Info display only for
georeferenced data.
Using ImageInfo is a
good way to find out
if an image is
georeferenced. 
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