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LLAABBOORRAATTOORR  SSIIGG  11  

Introducere 

Open GIS – fundamente si concepte 

 

Definiţia Open GIS 

Geoprocesare deschisă si interoperabilă sau abilitatea de a partaja date eterogene si de a geoprocesa 

resurse, în mod transparent, în reţele de calculatoare. 

 

Specificaţia Open GIS 

Răspunde la probleme la nivel larg industrial 

Reprezintă un cadru de acces distribuit la date si resurse de geoprocesare 

Oferă dezvoltatorilor de programe din întreaga lume un model detaliat de interfeţe, interoperabile cu alte 

programe Open GIS 

Înţelegere a fenomenelor pentru reprezentarea Pământului - matematic si conceptual 

Model pentru implementarea serviciilor de acces, gestiune, manipulare, reprezentare, partajare a geodatelor 

în comunitatea informatică 

Cadrul pentru folosirea modelului deschis de geodate si modelului de servicii OGIS 

 

Beneficiile Open GIS 

Extinde beneficiile GIS - ului tradiţional 

Aduce “inter - operabilitate” între sisteme si date 

Stabileste un limbaj comun si “sistem unificat pentru informaţiile geografice” 

Creează sisteme folosind cele mai bune componente 

Asigură integrarea cu standardele software bazate pe componente 

Asigură cicluri de dezvoltare de aplicaţii rapid si eficient 

Evită redundanţa datelor 

Protejează investiţiile iniţiale în date si echipamente 

 

Ce este consorţiul Open GIS? 

Asociaţie non-profit dedicată promovării abordărilor noi tehnice si comerciale pentru geoprocesare 

interoperabilă 
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Participanţi: vânzători de software, hardware, baze de date, integratori de sisteme, companii de 

telecomunicaţii, furnizori de date si agenţii, universităţi 

 

Viziunea Consorţiului Open GIS 

Asupra infrastructurii naţionale si globale: geodatele si resursele geoprocesării trebuie să circule liber, 

complet integrate cu ultimele tehnologii de calcul distribuit 

 

Misiunea Consorţiului Open GIS 

Urmăreste integrarea totală a datelor geospaţiale si resurselor de geoprocesare în curentul informatic 

si folosirea intensivă a programelor pentru geoprocesare interoperabilă, comercială, pretutindeni în structura 

informaţională. 

 

Concluzie 

Lumea informatică a suferit o modificare în sensul progresului spre: 

componentizare 

calcul distribuit (în reţea), iar interfeţele OpenGIS fac posibilă geoprocesarea ca parte a acestui progres 

 

Instalarea produsului GIS GeoMedia Professional 

GeoMedia Professional foloseste Windows Installer pentru a instala programul. 

 

Etapele premergătoare instalării programului GeoMedia Professional 

1. Instalaţi sistemul de operare – dacă e necesar – conform instrucţiunilor de instalare furnizate de Microsoft. 

Pentru GeoMedia nu sunt necesare setări speciale, ci doar cele standard predefinite ale sistemul de operare 

din Windows NT –Workstation. 

2. Verificaţi dacă sistemul de calcul are resursele necesare specificate în documentaţia ReadMe a GeoMedia 

Professional 5.0, respectiv 250 MB spaţiu liber pe hard disk, 512 MB memorie RAM recomandat. 

3. Verificaţi dacă aveţi drept de administrator pe sistemul pe care intenţionaţi să instalaţi programul. 

4. Dacă doriţi să utilizaţi în GeoMedia Professional date provenite din alte sisteme GIS, cum sunt MGE, 

MGDM sau MGSM sau proiecte tabelare ODBC sau date provenite din sisteme CAD în care grafica are 

atribute atasate în baze de date, instalaţi drivere-le Open Database Connectivity (ODBC) corespunzătoare 

sistemului de management al bazelor de date pe care îl utilizează datele respective. Drivere-le ODBC 

adecvate le puteţi obţine de la furnizorul sistemului dvs. de gestiune de baze de date. 
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Notă: Pentru Windows NT, GeoMedia Professional necesită Microsoft Data Access (MDAC) 2.5 sau mai 

mult. MDAC 2.5 furnizează o serie de drivere ODBC. Se poate consulta web site - ul Microsoft Universal 

Data Access la http://www.microsoft.com/data pentru informaţii privind MDAC. Windows ME, Windows 

2000 si Windows XP includ MDAC în sistemul de operare si nu este necesară actualizarea programului 

MDAC. 

5. Pentru a utiliza server-ele de date Oracle® Relational Model sau Oracle Object Model trebuie să încărcaţi 

Oracle client înainte de instalarea programului GeoMedia Professional. 

6. Daca aveţi instalată o versiune mai veche de GeoMedia Professional trebuie să o dezinstalaţi înaintea 

instalării versiunii 5.0. Pentru aceasta operaţie folosiţi succesiunea de comenzi următoare Start -> Settings -> 

Control Panel -> Add / Remove -> alegeţi numele versiunii precedente a produsului. 

7. Verificaţi dacă este instalat Service Pack 6 pentru Windows NT 4.0. Dacă nu este, instalaţi-l. 

 

Pasi pentru instalarea produsului GeoMedia Professional 

1. Închideţi orice alt program Windows. 

2. Introduceţi CD - ul cu GeoMedia Professional în CD-ROM sau conectaţi-vă la directorul partajat din reţea 

care conţine GeoMedia Professional. 

3. Daca instalaţi de pe un drive partajat din reţea sau dacă procesul de instalare nu porneste imediat, se poate 

selecta Start -> Settings -> Control Panel -> se utilizează Add / Remove Programs Wizard pentru rularea 

programului Setup.exe sau prin dublu clic direct pe fisierul Setup.exe pentru a-l executa. 

4. La apariţia ferestrei de dialog GeoMedia Professional Setup, citiţi instrucţiunile si urmăriţi indicaţiile 

pentru a instala produsul pe drive - ul si calea pe care le doriţi. Restul setărilor sunt implicite. 

5. La terminarea procesului de instalare apăsaţi butonul Finish. 

6. Odată cu versiunea 5.0 a GeoMedia Professional a fost introdusă o nouă politică de licenţiere. Modul Node 

lock license permite instalarea programului GeoMedia Professional pe un anumit calculator. După instalare, 

la prima iniţializare (lansare) a GeoMedia Professional apare o fereastră de dialog care furnizează informaţia 

necesară pentru obţinerea licenţei pe acel post de lucru de la Intergraph. 

Pentru a obţine licenţa de la Intergraph aveţi nevoie de următoarele informaţii: 

- LAC – License Authentication Code, cod format din litere si cifre transmis separat, neinclus în program 

- HOSTID – acesta este codul furnizat într-o fereastră text la lansarea GeoMedia Professional. Acest cod 

identifică unic calculatorul pe care se instalează programul. Trebuie să copiaţi conţinutul acestei ferestre de 

dialog si să-l transmiteţi pentru obţinerea licenţei. 

Există câteva modalităţi de obţinere a licenţei 

- utilizând internetul la adresa http://www.intergraph.com/imgs/license, serviciu disponibil 24 din 24 ore 
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- contactând biroul Intergraph Computer Services (România) 

Intergraph vă va trimite un fisier prin e-mail sau tipărit conţinutul acestuia prin fax pe care va trebui să-l 

denumiţi GeoMedia_Professional.lic si să-l plasaţi în directorul Program al aplicaţiei (de exemplu: 

C:\Program Files\GeoMediaProfessional\Program). Nu aveţi voie să modificaţi conţinutul acestui fisier 

(altfel licenţa nu funcţionează). 

 

Dezinstalarea produsului GIS GeoMedia Professional 

Dacă aţi hotărât că e necesară dezinstalarea produsului GeoMedia Professional din sistemul dvs. 

folosiţi următoarea procedură: 

1. Selectaţi    Start -> Settings -> Control Panel -> Add/Remove Programs 

2. În cutia de dialog Add/Remove Programs Properties selectaţi GeoMedia Professional din lista. 

3. Clic pe butonul Remove. 

4. La mesajul Confirm File Deletion (Confirmaţi stergerea) apăsaţi butonul Yes. 

5. Verificaţi că nu au rămas informaţii inutile în registrii calculatorului după dezinstalarea programului 

GeoMedia Professional, folosind programul Regedit.exe. 

6. Start -> Run -> Regedit 

7. GeoMedia Professional se înregistrează sub HKEY_CURRENT_USER\Software\Intergraph si 

HKEY_LOCAL_MACHINE\Software\Intergraph. Trebuie sters conţinutul Intergraph, dacă nu sunt instalate 

si alte produse Intergraph. In cazul în care mai aveţi instalate si alte produse, verificaţi cu atenţie ce stergeţi. 
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GeoMedia Professional - Ghidul cursului 

 

1. Iniţiere în GeoMedia Professional 

Acest curs prezintă caracteristicile de bază ale produsului GeoMedia Professional, folosind o bază de 

date a României, Romania.mdb, creată în scopuri didactice (toate datele necesare sunt localizate în directorul 

C:\Curs). 

PROBLEMA: selectaţi localizările posibile pentru amplasarea unei staţiuni de schi si apoi creaţi o hartă a 

staţiunii de schi (generaţi planul de detaliu al staţiunii) utilizând capabilităţile de captură de date ale 

produsului. 

 

1.1.Pornirea programului GeoMedia Professional 

Pentru a verifica dacă instalarea a fost efectuată corect porniţi GeoMedia Professional prin selectarea  

Start -> Programs -> GeoMedia Professional -> GeoMedia Professional. 

La prima lansare apare fereastra de dialog Welcome to GeoMedia Professional. Acest wizard vă ajută 

să începeţi o sesiune de lucru cu GeoMedia Professional oferindu-vă câteva opţiuni de selecţie: 

- Learning GeoMedia Professional: determină lansarea unui curs GeoMedia Professional care vă 

prezintă principalele comenzi 

- Open existing GeoWorkspace: permite deschiderea ferestrei de dialog Open GeoWorkspace din 

care se pot selecta si deschide fisierele GeoWorkspace existente 

- Create new GeoWorkspace: determină afisarea ferestrei de dialog New ce permite crearea unui 

fisier de lucru nou prin alegerea unui model (template) si apăsarea butonului OK 

- Don't display this startup screen again: permite activarea sau dezactivarea (setarea on/off) a 

Welcome to GeoMedia Professional Wizard astfel încât această primă fereastră poate să mai apară sau nu la 

următoarea lansare a programului. Chiar dacă această fereastră nu mai apare, se pot: 

i. deschide fisierele utilizând secvenţa de comenzi File -> Open GeoWorkspace; 

ii. crea noi fisiere utilizând secvenţa de comenzi File -> New GeoWorkspace; 

iii. si lansa cursul Learning, utilizând secvenţa de comenzi Help > Learning GeoMedia Professional. 

 

1.1.1. Crearea unui GeoWorkspace 

GeoWorkspace - ul este aria de lucru prin care vizualizaŢi date geografice. Dacă aveŢi o conexiune la 

un depozit de date (warehouse) de tip read/write, asa cum se va prezenta ulterior, pot fi plasate si manipulate 

date din GeoWorkspace. 
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LansaŢi GeoMedia, dacă nu rulează încă. 

1. Dacă apare o fereastra de dialog Welcome to GeoMedia Professional, selectaŢi butonul Create new 

GeoWorkspace      sau            SelectaŢi File> New GeoWorkspace din bara de meniu. 

2. În fereastra de dialog New, acceptaŢi template - ul implicit, normal.gwt, asigurându-vă că iconiŢa si 

opŢiunea Document sunt selectate si apoi apăsaŢi butonul New. 

În acest mod s-a creat GeoWorkspace-ul si a primit numele implicit GeoWorkspace1, vizibil pe prima linie 

a ecranului (bara de titlu Windows). GeoWorkspace - ul conŢine setările implicite, respectiv un sistem de 

coordonate implicit, o  legenda goală si o fereastră hartă. 

Fereastra hartă are titlul implicit MapWindow1 si este fereastră în care se vizualizează elementele grafice, 

imaginile si etichetele elementelor reprezentate. 

 

1.1.2. Salvarea unui GeoWorkspace 

Înainte de a continua salvaŢi GeoWorkspace - ul utilizând comanda: 

1. SelectaŢi File> Save GeoWorkspace. 

Automat salvarea se va realiza in directorul C:\GeoWorkspaces (veŢi vedea unde se poate seta calea 

implicită pentru salvarea fisierului spaŢiu de lucru în următorul paragraf “OpŢiuni pentru localizarea 

fisierelor”). 

2. În câmpul File name, stergeŢi textul existent si tastaŢi : Curs. 

3. ApăsaŢi butonul Save. 

Fisierul este salvat în directorul C: \GeoWorkspaces (sau pe drive-ul unde s-a instalat directorul 

implicit pentru fisierele spaŢiu de lucru) cu numele Curs.gws. 

NOTĂ: De oricâte ori se părăseste acest fisier sau GeoMedia, se recomandă salvarea fisierului 

GeoWorkspace. 

 

1.1.3. OpŢiuni pentru localizarea fisierelor 

Localizarea referinŢelor către fisierele GeoWorkspace si Warehouse poate fi setată de către utilizator 

astfel: 

1. Din meniul Tools-> Options. 

2. SelectaŢi tab - ul File Locations din fereastra de dialog Options. 

3. Calea de căutare pentru un anumit tip de fisiere File Types poate fi schimbată selectând butonul Modify. 

 



7 

 

 

4. În acest exerciţiu nu se modifica nici o cale referinţă. 

5. Priviţi doar aceasta fereastră si observaţi opţiunile disponibile, fără a le schimba. 

6. Selectaţi butonul OK pentru închiderea ferestrei de dialog Options. 

 

1.2. Folosirea Warehouse-urilor pentru conectarea la date 

Un warehouse este o sursă de date geografice (bază de date) pentru GeoMedia Professional. Fiecare 

warehouse conŢine doar un tip de date geografice, respectiv Access, MGE, FRAMME, MGE Segment 

Manager, ARC/INFO, Oracle, ArcView, MapInfo, MGDM sau CAD. 

În acest capitol vă veŢi conecta la o bază de date existentă (Acces) pentru a vizualiza sau interoga 

ulterior datele. În plus veŢi crea un warehouse de tip read/write (Acces) în care veŢi scrie sau importa date. 

De asemenea veŢi realiza conectarea la un warehouse CAD (AutoCad), veŢi vizualiza datele si le veŢi 

importa în baza de date de tip read/write. 

 

1.2.1. Conectarea la un Warehouse Access existent 

GeoMedia Professional permite conectarea la /si afisarea mai multor tipuri de date geografice 

simultan. De exemplu, vă puteŢi conecta la un warehouse MGE, unul FRAMME si unul ARC/INFO si să 

vizualizaŢi date din aceste surse diferite ca si cum ar fi o hartă integrată. 
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Pentru a demonstra această funcŢionalitate vă veŢi conecta la depozitul de date Access, 

Romania.mdb si veŢi importa unele date ale acestuia într-un nou depozit Access pe care-l veŢi crea, 

Curs.mdb. OpŢiunea alegerii numai a unui set de informaŢii se foloseste când nu aveŢi nevoie de toate 

datele conŢinute în Romania.mdb. Astfel se vor importa doar acele clase de elemente caracteristice necesare 

lucrului. Acesta este doar unul din avantajele arhitecturii GeoMedia Professional! 

In GeoMedia Professional, un element grafic este o entitate geometrică reprezentată pe hartă prin 

geometrie si definită prin atribute non - grafice în baza de date. 

O clasa de elemente grafice reprezintă o mulŢime de instanŢe ale unui element grafic. 

Setul de date exemplu, conŢine mai multe clase de elemente grafice, printre care: Judete, Orase, 

Drumuri_europene. 

Exemple: 

- Ilfov este un element grafic din clasa de elemente grafice Judete 

- Bucuresti este un element grafic din clasa de elemente grafice LocalităŢi 

Pentru început, va conectaŢi la warehouse - ul din care doriŢi să importaŢi datele Romania.mdb. 

Acesta este warehouse - ul sursă. 

 

1. Se selectează Warehouse -> New Connection. 

Wizard-ul Warehouse Connection Wizard afisează diferitele tipuri de warehouse - uri la care vă 

puteŢi conecta. 

2. Din lista Connection Type selectaŢi Access Read-Only. Deoarece deschideŢi o conexiune în mod read-

only, nu exista pericolul ca accidental să modificaŢi conŢinutul fisierului Romania.mdb. 

3. În câmpul Connection name, stergeŢi textul curent si tastaŢi “Conexiune la Date Romania”. 

4. OpŢional - În câmpul Connection Description, tastaŢi “Date didactice”. 

Este un câmp descriptiv folosit doar pentru informare. Nu este obligatoriu să fie completat. 

5. Pentru selectarea fisierului bază de date (sursa de date) apăsaŢi butonul Browse. 

6. SelectaŢi Romania.mdb (din directorul C:\Curs) si apoi apăsaŢi butonul Open. 

7. ApăsaŢi butonul Ok. 
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1.2.2. Adăugarea claselor de elemente 

VeŢi afisa în fereastra hartă două clase de elemente grafice dintr-un Warehouse de tip read-only. 

1. SelectaŢi Legend -> Add Legend Entries. 

2. In fereastra de dialog Add legend Entry, click pe (+) din dreptul conexiunii ‘Conexiune la Date 

Romania’. 

3. SelectaŢi clasele de elemente Den_judete si Judete din lista derulantă care conŢine clasele de elemente. 

4. ApăsaŢi butonul OK. 

JudeŢele si etichetele acestora (labels) sunt adăugate în legendă si totodată afisate în fereastra hartă 

(map window). 

5. MaximizaŢi fereastra hartă folosind cunostinŢele lucrului cu mediul Windows, clic pe icon – ul din coltul 

stâng sus si selectând Maximize din meniu sau folosind butonul din mijloc dreapta sus. 

6. Selectaţi View -> Fit All pentru vizualiza harta în întreaga fereastră hartă. 

 

1.2.3. Salvarea sistemului de coordonate si localizarea directorului Curs 

GeoMedia Professional furnizează un sistem de coordonate implicit pentru scopuri de afisare. 

Suplimentar, GeoMedia Professional oferă opŢiuni care permit setări de noi sisteme de coordonate si 

transcalcule automate între sistemele de coordonate predefinite. Sunt posibile setări de sisteme de coordonate 

pentru vizualizare, diferite de cele ale bazei de date în care se salvează datele. InformaŢiile despre sistemele 

de coordonate se înregistrează împreună cu datele (în baza de date). Acesta este un avantaj în cazul portării 

datelor în alte sisteme GIS care vor citi automat aceste informaŢii despre sistemul de coordonate. 
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În acest exerciŢiu sistemul de coordonate va fi setat la cel al clasei de elemente Judete, salvând mai 

întâi sistemul de coordonate pentru Judete. Ulterior se va folosi acest nou sistem de coordonate. 

Sistemul de coordonate a fost setat la conectarea la baza de date Romania.mdb. 

1. SelectaŢi Warehouse -> Feature Class Definition. 

2. DeschideŢi Conexiune la Date Romania prin clic pe semnul (+) din dreptul numelui conexiunii. 

3. Din lista claselor de elemente selectaŢi Judete si apăsaŢi Review. 

4. SelectaŢi butonul Properties. 

5. În fereastra de dialog Coordinate System Properties, selectaŢi tab - ul Projection Space. 

6. ObservaŢi că la Projection algorithm este selectat Three-Step Stereographic. 

7. ApăsaŢi butonul Save As si alegeŢi directorul C:\Curs în care doriŢi să salvaŢi fisierul. 

ObservaŢie: Toate datele necesare sunt localizate în directorul Curs. LocaŢia implicită este C:\Program 

Files\GeoMedia\Learning. Pentru a slava datele rezultate se va seta directorul C:\Curs creat. 

8. În câmpul File name tastaŢi Romania.csf. 

9. ApăsaŢi butonul Save. 

10.ApăsaŢi butonul Cancel în fereastra de dialog Coordinate System Properties. 

11.ApăsaŢi Close atât în fereastra de dialog Review cât si în Feature Class Definition. 

12.VerificaŢi dacă Romania.csf a fost salvat în directorul C:\Curs sau dacă nu aveŢi drept de scriere în acea 

locaŢie selectaŢi un alt director. 

 

1.2.4. Încărcarea sistemului de coordonate 

În acest exerciŢiu se va încărca sistemul de coordonate salvat anterior. 

1. SelectaŢi View -> GeoWorkspace Coordinate System. 

2. ApăsaŢi Load. 

3. SelectaŢi Romania.csf salvat în directorul C:\Curs si apăsaŢi Open. 

4. SelectaŢi tab - ul Projection Space si observaŢi ca în câmpul Projection algorithm este selectat Three-

Step Stereographic, la fel ca sistemul de coordonate al clasei de elemente Judete. 

5. ApăsaŢi OK. 

 

1.2.5. Setarea proprietăŢilor de afisare 

VeŢi seta scara nominală si scara de afisare pentru fereastra hartă. Până când vă veŢi familiariza cu 

comportamentul comenzii Display Properties, puteŢi asociaŢi scara nominală cu scara hărŢii plotate. 

Aceasta scară trebuie să aproximeze scara la care au existat datele în forma primară (pe hârtie), pe care o 

cunoasteŢi sau nu. Definirea setării stilurilor (grosimea liniilor, dimensiunea textelor, mărimea simbolurilor) 
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se poate face astfel încât să reflecte această scara. Scara de afisare este scara la care obiectele hartă sunt 

afisate în fereastra hartă. De exemplu, când măriŢi (zoom in) sau micsoraŢi (zoom out) elementele din 

fereastra hartă scara afisată se va mări sau micsora cu un factor predefinit sau setat. 

Setările de definire a stilurilor de afisare (grosimea liniilor, dimensiunea textelor, mărimea 

simbolurilor) se reflectă diferit în funcŢie de opŢiunile setate: “dimensiunea rămâne constantă când scara de 

afisare se modifica” (Size remains constant as display scale changes) sau invers, “Dimensiunea se modifică 

când scara de afisare se modifică” (Size changes as display scale changes (true at nominal map scale). În 

cazul textelor, dacă este setată opŢiunea “Dimensiunea rămâne constantă când scara de afisare se modifică” 

(Size remains constant as display scale changes ) nu vor apărea modificări la schimbările scării de afisare (in 

urma aplicării comenzilor de zoom in sau out). Sunt posibile modificări doar când se modifică scara 

nominală a hărŢii. Textele care au setată opŢiunea Size changes as display scale changes (true at nominal 

map scale) vor fi afisate la scara nominală setată si se vor modifica în dimensiune proporŢional cu 

schimbarea relativă faŢă de scară nominala de afisare. 

Notă: Există două modalităŢi prin care puteŢi defini setarea stilurilor. 

- fereastra de dialog Display Properties permite setarea stilurilor pentru toate intrările din legendă; 

- se poate seta individual pentru fiecare intrare în legendă prin click pe intare si selectarea Style Scaling > 

Paper dacă este setată opŢiunea Paper (size is true at nominal map scale), sau Style Scaling > View dacă 

este setată opŢiunea View (size is true at any display scale). 

 

1. SelectaŢi View -> Display Properties.   Apare fereastra de dialog Display Properties. 

2. În lista derulantă a opŢiunii Display scale selectaŢi 2,500.000 (2,5 milioane). 

3. In câmpul Nominal map scale, tastaŢi 2,000,000 (2 milioane). 

4. SelectaŢi opŢiunea PAPER – Size  changes as display scale changes (true at nominal map scale). 

Toate intrările legendei vor fi afisate funcŢie de aceasta setare. 

5. ApăsaŢi butonul Apply. 

6. Clic Close. 
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7. UitaŢi-vă în coltul din dreapta-jos. VeŢi vedea afisată scara (1:2,500,000). Dacă nu vedeŢi aceasta setare, 

selectaŢi Tools -> Options. ApăsaŢi tab - ul General si asiguraŢi-vă că în această fereastră sunt selectate 

opŢiunile Show status bar si Show display scale. ApăsaŢi butonul OK al ferestrei de dialog Options. 

 

1.2.6. Schimbarea stilului de afisare a etichetelor 

GeoMedia prin comanda Legend > Styles, permite crearea, modificarea, denumirea si salvarea 

stilurilor. 

În exerciŢiu, veŢi schimba stilul pentru etichetele clasei de elemente Den_judete (veŢi micsora si 

îngrosa textele). 

1. Dublu click pe simbolul intrării în legendă al clasei Den_judete. Se deschide caseta de dialog Legend 

Entry Properties. 

 

2. În partea dreaptă în secŢiunea Style, selectaŢi dimensiunea 8 din lista derulantă a opŢiunii Size si 

selectaŢi opŢiunea B (bold). 

3. ApăsaŢi Ok, pentru a părăsii caseta Legend Entry Properties. Denumirea judeŢelor a fost modificată cu 

noile valori. 

 

1.2.7. Salvarea stilului 

În continuare veŢi schimba stilul clasei de elemente Judete si veŢi salva acest stil pentru a fi utilizat 

ulterior. Pentru început veŢi crea un nou stil, îl veŢi denumi si după aceea veŢi înlocui stilul curent al 

judeŢelor cu acest noul stil. 

1. SelectaŢi Legend > Styles. 

2. Din bara de meniu a casetei de dialog, click pe New si selectaŢi Area Style. 

3. În sectiunea Style apare intrarea New Area Style, pe care o veŢi redenumi Stil curs. 

4. Dublu click pe stilul denumit Stil curs care deschide caseta de dialog Style Properties. 

Notă: stilul arie conŢine 2 stiluri: stilul linie pentru margine si stilul pentru umplere. 

5. În caseta de dialog Style Properties, selectaŢi opŢiunea Simple Line Style (de sub Boundary Styles). 

Setările pentru Boundary Style sînt afisate în partea dreaptă a casetei de dialog. 

6. VeŢi schimba culoarea marginii, prin click pe butonul Color. În caseta de dialog Color selectaŢi culoarea 

gri închis-click Ok. 

7. SelectaŢi opŢiunea Simple Fill Style (de sub Fill Styles). ). Setările pentru Fill Style sînt afisate în partea 

dreaptă a casetei de dialog. 
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8. VeŢi schimba culoarea de umplere, prin click pe butonul Color. În caseta de dialog Color selectaŢi 

culoarea bleu-click Ok. 

9. VeŢi păstra valoarea 0 pentru opŢiunea Translucency. 

Notă: Pentru valoarea 0 în câmpul Translucency stilul de umplere este opac, iar pentru valoarea 100 stilul 

este complet transparent. 

10.Click OK în caseta de dialog Style Properties. 

11.Click Close în caseta de dialog Style. 

Odată ce a fost creat noul stil, îl veŢi asocia intrării în legendă Judete. 

12.În legendă, dublu click pe intrarea Judete. Apare caseta de dialog Legend Entry Properties. 

13.În secŢiunea Named Styles, selectaŢi Stil curs 

14.Click OK în caseta de dialog Legend Entry Properties. 

15.SalvaŢi GeoWorkspace-ul selectând File > Save GeoWorkspace. 
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1.3. Lucrul cu Legenda 

Legenda reprezintă centrul de control interactiv care determină ceea ce se afisează în fereastra hartă. 

Prin intermediul legendei se controlează cum sunt afisate si cum arată obiectele hărŢii: clasele de elemente 

grafice, imaginile, rezultatele interogărilor, afisările tematice. ObservaŢi că statele si numele acestora sunt 

afisate. Numele statelor sunt prea mici pentru a fi afisate de aceea trebuie mărite. 

 

1. În legendă, selectaŢi intrarea Den_Judete, click buton dreapta mouse si din lista derulantă selectaŢi 

opŢiunea Display by Scale. 

ObservaŢie: după ce a fost setată opŢiunea Display by Scale va apărea o scară în partea stângă a intrării din 

legendă, indicând faptul că proprietăŢile de afisare ale acestei clase de elemente sunt corespunzătoare cu 

scara de afisare din fereastră. 

2. Click buton dreapta mouse pe Den_Judete si selectaŢi opŢiunea Display Scale Range. 

3. În caseta de dialog Scale Range, setaŢi scara de afisare. 

Fereastra de dialog Scale Range va permite setarea scării de afisare a elementelor grafice. Grafica va 

fi afisată în fereastra hartă când scara de afisare se potriveste cu cea a domeniului din legenda, iar Display 

este setat la By Scale; altfel, când nu este îndeplinită această condiŢie nu va fi afisată. 

4. SchimbaŢi câmpul Minimum la 1,000. 

5. Nu schimbaŢi câmpul Maximum. ApăsaŢi butonul OK pentru închiderea ferestrei de dialog Scale Range. 

6. ApăsaŢi butonul OK pentru a închide fereastra de dialog Legend Properties. 

Etichetele judeŢelor Den_judet sunt afisate acum suficient de mari pentru a putea fi citite. 

 

1.3.1. Analiza ProprietăŢilor Legendei 

Afisarea caracteristicilor ferestrei hartă în legendă poate fi controlată. Această caracteristică e utilă 

pentru încorporarea hărŢii în alte documente. 

 

1. Click buton dreapta mouse oriunde în legendă si selectaŢi opŢiunea Properties 

2. În câmpul Title denumiŢi legenda în Legendă curs 

3. În câmpul Background color schimbaŢi culoarea legendei în galben deschis. 

4. În câmpul Legend entry title click pe butonul Font si selectaŢi Font Arial, Font Style Bold si Size 9 

Click Ok în caseta Font 

5. În câmpul Statistic, verificaŢi că este selectată opŢiunea Count of feature with geometry. 
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6. Click Ok în caseta Legend Properties. 

1.3.2. Crearea unui Legend Group 

Legenda are două taburi, Display Order si Groups. 

Tabul Display Order redă ordinea în care intrările în legendă sînt afisate. Acest tab se utilizează 

pentru schimbarea ordinii de afisare; spre exemplu este recomandat ca etichetele să fie afisate primele, 

urmate de simboluri, apoi de linii si ultimele ariile. 

Tabul Groups permite crearea grupurilor pentru elementele din legendă si plasarea oricărei intrări 

dorite în grup in funcŢie de modul dorit; spre exemplu se pot grupa elementele după frecvenŢa cu care sînt 

utilizate, după geometrie sau orice mod care te ajută în organizarea elementelor. 

În continuare veŢi crea un grup în care veŢi plasa intrările care nu vor fi utilizate frecvent. 

1. Click pe tabul Groups din legendă. 

2. Click buton dreapta mouse în spaŢiul liber din legendă si selectaŢi New Group. 

3. RedenumiŢi acest grup în Neutilizate frecvent, apoi apăsaŢi Enter sau click oriunde în afara noii intrări. 

Grupul creat apare în tabul Group 

 

4. SelectaŢi File > Save GeoWorkspace pentru a salva GeoWorkspace-ul. 

1.4. Crearea unui Warehouse si adăugarea datelor 

În secŢiunea anterioară, aŢi creat o conexiune de tip read-only la baza de date Romania.mdb. 

Deoarece această conexiune este de tip read-only, permite doar citirea datelor nu si introducerea datelor noi.  

În continuare veŢi crea o nouă baza de date Acces, denumită Curs.mdb, veŢi insera o imagine, după 

care vom importa date din baza de date Romania.mdb în baza de date Curs.mdb. 

 

1.4.1. Crearea unui Warehouse Access 

Un warehouse Access (Oracle, SQL) reprezintă singurul tip de warehous pe care poate fi creat cu 

drept de scriere din GeoMedia Professional. GeoMedia poate, de asemenea, să scrie în baze de date Oracle 

sau SQL Server dar aceste warehouse-uri trebuie să fie create extern mediului GeoMedia. 
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Alte tipuri de warehouse - uri provenite din produse GIS cum sunt: MGE, FRAMME, ArcView 

ARC/INFO etc. sunt considerate de tip read-only (nu se pot scrie date si nu se pot modifica datele; dacă se 

doreste totusi mai mult decât consultare se poate executa importul datelor într-o bază de date care permite 

dreptul de scriere). 

1. SelectaŢi Warehouse > New Warehouse. 

2. AcceptaŢi template - ul implicit normal.mdt, asigurându-vă că normal.mdt apare în câmpul File name si 

opŢiunea Document e selectată, după care apăsaŢi butonul New. 

3. SchimbaŢi directorul în C:\Curs (acesta este directorul în care trebuie să salvaŢi fisierele pe care le 

lucraŢi.) 

4. În câmpul File name, tastaŢi numele Curs pentru warehouse. 

5. AsiguraŢi-vă că Save as type este setat Access Databases (*.mdb) si click butonul Save. Fisierul este 

salvat în directorul Warehouses cu numele Curs. mdb. 

Pentru moment acest warehouse este gol. Ulterior veŢi importa date în acest warehouse din 

conexiunea Conexiune la Date Romania. 

 

1.4.2. Inserarea unei Imagini 

VeŢi insera o imagine raster a României predefinită creată în scop didactic, existentă în directorul 

C:\Curs. Imaginea poate fi inserată numai într-un warehouse de tip read-write. 

 

1. SelectaŢi Insert > Georeferenced Images. 

2. Din lista derulantă Georeference mode selectaŢi opŢiunea GeoTIFF. 

3. În câmpul Folder, apăsaŢi butonul Browse pentru a selecta directorul C:\Curs. 

4. SelectaŢi Romania.tif din lista Available files si apăsaŢi butonul “>” pentru a adăuga numele acestui 

fisier în lista Selected files. 

ObservaŢie: Dacă doriŢi să inseraŢi mai multe imagini în acelasi timp selectaŢi imaginile dorite si apăsaŢi 

butoanele „>” sau „>>”. 

5. În spaŢiul Insert images, asiguraŢi-vă că este selectată conexiunea Curs din câmpul Warehouse. 

6. În câmpul Feature classes with matching coordinate system , tastaŢi numele clasei de elemente pentru 

această imagine – GeoTif (fără spaŢii). 

7. SelectaŢi Add new legend entry for feature class. 

8. ApăsaŢi OK în fereastra de dialog Insert Georeferenced Images. Imaginea este inserată. 
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9. Pentru a schimba stilul, dublu click pe iconul intrării GeoTif. Apare fereastra de dialog Legend Entry 

Properties. 

10.În fereastra Legend Entry Properties, în secŢiunea Style tastaŢi 25 pentru Brightness. 

11.ApăsaŢi butonul OK în fereastra de dialog Legend Entry Properties. 

12.În tabul Display Order din legendă, selectaŢi intrarea GeoTif si aduceŢi-o pe ultimul loc în legendă. 

  

13.În legendă, click dreapta mouse pe intrarea GeoTif si selectaţi Locatable Off. 

14.Selectaţi File > Save GeoWorkspace pentru a salva GeoWorkspace-ul. 

1.4.3. Importul datelor dintr-un Warehouse Access existent 

A importa date înseamnă să se copieze date dintr-un warehouse sursă într-un warehouse destinaţie. 

PuteŢi importa date din orice Warehouse suportat de GeoMedia Professional fie într-un warehouse Access 

fie într-unul Oracle sau SQL. 
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1. SelectaŢi Warehouse > Output To Feature Classes. 

2. AsiguraŢi-vă este selectată în câmpul Source connections and queries conexiunea Conexiune la Date 

Romania si în câmpul Target connection conexiunea Curs 

Warehouse-ul sursa este Romania.mdb si warehouse-ul destinaŢie este Curs.mdb. 

  

3. În câmpul Feature Classes, selectaŢi clasele de elemente grafice Judete si Lim_admin 

4. AsiguraŢi-vă că este selectată opŢiunea Display target feature classes in map window 

5. ApăsaŢi tab-ul Advanced 

6. SchimbaŢi numele clasei de elemente grafice Judete în JudeteImport si Lim_admin în 

Lim_adminImport prin clic pe numele câmpului si înlocuind vechiul nume prin stergere si tastarea celui 

nou. 
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Nota: SpaŢiile (blanc-urile) nu sunt permise în numele claselor de elemente grafice. 

7. ApăsaŢi butonul Ok. La mesajul care vă întreabă dacă doriŢi să continuaŢi, click Yes. 

Nota: Comanda Output To Feature Classes salvează rezultatul importului într-un fisier GMOTTS.log 

localizat în directorul Warehouses. 

8. Click OK când este afisat mesajul Output complete. Elementele grafice importate JudeteImport si 

Lim_adminImport apar in fereastra hartă. 

JudeteImport si Judete sunt clase de elemente identice, diferenŢa rezultând din faptul că JudeteImport 

este read-write (la fel si Lim_adminImport) iar Judete este read-only. 

9. În legendă selectaŢi Judete si Lim_adminImport (tasta CTRL apăsată), apoi apăsaŢi pe butonul din 

dreapta al mouse-ului si clic Display Off. 

10.În tabul Groups, selectaŢi cele două intrări, Lim_adminImport si Judete si mutaŢi-le (prin tragere) în 

grupul Neutilizate frecvent. 

 

11.Dublu click pe iconul intrării în legendă JudeteImport. 

12. În fereastra de dialog Legend Entry Properties, în secŢiunea Named Styles, selectaŢi Stil curs. 
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13.ApăsaŢi butonul OK în fereastra de dialog Legend Entry Properties. Clasa de elemente JudeteImport 

va prelua setările stilului creat anterior (culoarea gri pentru margine si bleu pentru umplere). 

14.În legendă, în tabul Display Order, selectaŢi Den_judete si aduceŢi-l pe primul loc în legendă. 

15.Salvaţi GeoWorkspace-ul. 

 

1.4.4. Crearea unei categorii 

Categoriile au rolul de a clasifica sau grupa clasele de elemente si interogările. Odată creată o 

categorie, orice clasă de elemente sau interogare pe care o plasezi in această categorie poate fi selectată direct 

din această categorie, mai degrabă decât din conexiunea originală sau sursa de date.  

Categoriile pot fi create în funcŢie de o anumită tematică sau după frecvenŢa cu care sînt utilizate. În 

continuare veŢi crea categoria Utilizate frecvent în care veŢi plasa clasele de elemente Lim_adminImport si 

JudeteImport. 

1. SelectaŢi Warehouse > Categories. 

2. În fereastra de dialog Categories, selectaŢi New Categories. 

3. În caseta de dialog New Categories, în câmpul Name, denumiŢi noua categorie Utilizate frecvent - click 

Ok. 
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4. SelectaŢi categoria creată anterior Utilizate frecvent si apăsaŢi butonul Add Feature. 

5. În caseta Add Feature, deschideŢi conexiunea Curs si selectaŢi clasele de elemente JudeteImport si 

Lim_adminImport. 

6. ApăsaŢi butonul Ok în fereastra de dialog Add Feature. 

7. ApăsaŢi butonul Close în fereastra de dialog Categories.  Categoria Utilizate frecvent a fost creată si 

claselele de elemente JudeteImport si Lim_adminImport au fost adăugate în această categorie. De acum, 

aceste clase de elemente pot fi selectate direct din această categorie. 

8. SalvaŢi GeoWorkspace-ul. 
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1.5. Lucrul cu hărŢile tematice si obiectele hartă 

O hartă tematică foloseste culori si pattern-uri pentru afisarea valorilor diferite ale datelor de tip atribut în 

fereastra hartă. Un atribut este o informaŢie non-grafică stocată în clasa de elemente odată cu geometria 

elementului. Datele de tip atribut sînt afisate sub formă de coloane în baza de date. Valoarea atributului este 

un câmp în coloanele asociate elementului grafic. 

 

1.5.1. Crearea unei HărŢi Tematice (Thematic Map) 

VeŢi crea o hartă tematică ce afisează atributele Stratm_zapada (strat mediu de zăpadă), după domeniul de 

valori ale elementelor grafice JudeteImport. Harta tematică vă ajută în luarea deciziei de amplasare a 

staŢiunii de ski (ref. PROBLEMA). 

1. Înainte de a crea harta tematică renunŢaŢi la afisarea imaginii raster prin clic dreapta pe intrarea legenda 

corespunzătoare (Geotif) si selectând Display Off. 

2. În legendă, în tabul Groups, selectaŢi imaginea rastru si mutaŢi-o în grupul Neutilizate frecvent. 

 

3. SelectaŢi Legend > Add Thematic Legend Entry. 

4. In fereastra de dialog Add Thematic Legend Entry, în secŢiunea Input feature deschideŢi lista derulantă 

si selectaŢi semnul (+) din faŢa categoriei Utilizate frecvent. 

5. Din lista claselor de elemente grafice pe care le conŢine, selectaŢi JudeteImport. 

 

6. În câmpul Type, selectaŢi Range Thematic. 
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Notă: Această opŢiune defineste modul în care sînt afisate datele: Unique Value Thematic se bazează pe 

valori individuale, unice ale atributului selectat, în timp ce Range Thematic se bazează pe domenii de valori. 

7. SelectaŢi lista derulantă Attribute for classification si selectaŢi Stratm_zapada. 

8. ApăsaŢi butonul Classify. 

9. În caseta de dialog Classify selectaŢi Equal Count for the Classification technique – click Ok. 

10.PăstraŢi opŢiunea Assign colors si din lista derulantă de dedesubt selectaŢi culorile dorite. 

 

11.Click buton Ok în ferestra de dialog Add Thematic Entry. 

Notă: Harta tematică este afisată în culorile selectate, în funcŢie de atributul Stratm_zapadă. În dreptul 

intrării tematice JudeteImport din legendă, se pot vedea domeniile de valori si numărul de judeŢe din fiecare 

domeniu. În acest moment denumirea judeŢelor este acoperită de harta tematică. 

12.În legendă, în tabul Display Order, poziŢionaŢi cursorul deasupra intrării Den_judete, apăsaŢi butonul 

din stânga al mouse-lui si trageŢi de intrare până o mutaŢi pe primul loc. Numele judeŢelor apar din nou în 

fereastra hartă deoarece acum sunt afisate deasupra tuturor elementelor legendei. 

13.SalvaŢi GeoWorkspace-ul. 

 

1.5.2. Modificarea HărŢii Tematice 

În continuare veŢi modifica proprietăŢile hărŢii tematice prin modificarea marginii judeŢelor. 

1. Dublu click pe iconul intrării tematice JudeteImport. Apare ferestra de dialog Legend Entry Properties. 
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2. În fereastra Legend Entry Properties, click pe butonul Base style. Apare ferestra de dialog Select Style. 

3. În fereastra Select Style, sub grupul Boundary, schimbaŢi grosimea Width în 2.000 - Click Ok în 

fereastra Select Style, click Ok în fereastra Legend Entry Properties. 

1.5.3. Selectarea obiectelor hărŢii 

PuteŢi selecta obiectele hărŢii pentru a indica programului GeoMedia Professional că doriŢi să le folosiŢi ca 

intrare pentru comenzi de tip mutare, editare sau stergere. 

1. AsiguraŢi-vă că instrumentul Select din bara de instrumente este selectat 

Cursorul din fereastra hartă devine o săgeată cu un indicator de localizare a zonei în vârf. 

Zona de localizare este aria în care cercul de la capătul săgeŢii defineste domeniul în care obiectele pot fi 

localizate. Dimensiunea zonei de localizare poate fi setată utilizând Tools > Options > SmartLocate, dar nu 

o veŢi schimba la acest exerciŢiu. 

2. MutaŢi cursorul mouse-ului peste câteva dintre judeŢele de pe hartă fără să apăsaŢi butonul mouse-ului. 

ObservaŢi că pe măsură ce se execută această defilare peste judeŢe, aceste obiecte ale hărŢii se afisează în 

altă culoare. Aceasta indică faptul că elementul a fost localizat. 

3. MutaŢi cursorul peste numele judeŢului BRASOV. JudeŢul se colorează altfel. 

4. ApăsaŢi butonul stâng al mouse-ului. ObservaŢi că judeŢul are o altă culoare acum. Aceasta este culoarea 

de selecŢie, care indică faptul că obiectul a fost selectat. 

Nota: Dacă apare fereastra de dialog PickQuick, închideŢi-o si selectaŢi alt judeŢ. Culoarea cu care sînt 

afisate elementele selectate se poate schimba astfel: 

5. SelectaŢi Tools> Options. 

6. Pe tab-ul Map Display, alegeŢi alte culori pe care le preferaŢi pentru opŢiunile Select si Highlight. 

7. Când ati selectat culorile, apăsaŢi butonul OK pentru a părăsi fereastra de dialog Options. 

8. ŢineŢi apăsată tasta CTRL si selectaŢi prin clic cu mouse-ul trei nume de judeŢ pentru a crea un set de 

selecŢie. 

Tastele CTRL sau SHIFT furnizează un mod util de selectare a mai multor obiecte odată, plasând 

aceste obiecte într-un set de selecŢie. 

9. Ca să vedeŢi cum se selectează un obiect care acoperă alt obiect, poziŢionaŢi cursorul pe hartă deasupra 

numelui (etichetei) judeŢului BRASOV. 

10.StaŢionaŢi cu mouse-ul si după câteva secunde, apare un cursor cu trei elipse. 

Cele trei elipse arată că în acea arie se află suprapuse mai multe obiecte. În acest caz, obiectele suprapuse 

sunt judeŢele. 

11.Când apar elipsele, apăsaŢi pe butonul stâng al mouse-ului. 

Apare fereastra de dialog Pick Quick, care vă permite să selectaŢi unul din elementele din zona respectivă. 
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Pentru aria selectată aveŢi trei opŢiuni prezente în fereastra de dialog Pick Quick: 

- prima - nr. 1 este pentru denumirea judeŢului, 

- a doua - nr. 2 este pentru judeŢele din harta tematică, 

- a treia - nr.3 pentru judeŢele care se află sub harta tematică, care par asemănăt cu cele de la nr.2. 

12.MutaŢi cursorul mouse-ului deasupra fiecărui buton (1,2,3) din fereastra dialog si observaŢi care din 

obiectele suprapuse se selectează. 

13.Clic pe numerele 2 sau 3 corespunzătoare judeŢului. JudeŢul este selectat. 

 

1.5.4. Revizuirea proprietăŢilor elementelor grafice 

PuteŢi afisa fereastra de dialog Properties pentru a revizui proprietăŢile elementelor grafice. 

1. PăstraŢi selectat elementul din etapa anterioară, sau selectaŢi un nou element si selectaŢi Edit>Select Set 

Properties.  Apare fereastra de dialog JudeteImport Properties. 

Această fereastră de dialog afisează informaŢii generale despre elementul selectat (tab-ul General), 

judeŢul BRASOV, precum si valorile non-grafice ale atributelor asociate elementului selectat (tab-ul 

Attributes), cum ar fi populaŢi, căderile medii de zăpadă. 

2. SelectaŢi tab-ul General. ObservaŢi că aria este afisată în metri păstraŢi. 

3. ApăsaŢi butonul Cancel pentru a părăsi fereastra de dialog. 

4. SelectaŢi View > GeoWorkspace Coordinate System. 

5. SelectaŢi tab-ul Units and Formats. 

6. În câmpul Type, alegeŢi Distance. În câmpul Unit, alegeŢi Km din lista derulantă pentru a stabili unitatea 

de măsură în kilometri. 

7. SelectaŢi Area din câmpul Type, si alegeŢi Km^2 (kilometri pătraŢi) din lista derulantă Unit. 

8. ApăsaŢi OK în ferestra de dialog GeoWorkspace Coordinate System. 

9. SelectaŢi Edit > Select Set Properties (sau dublu-clic pe judeŢul BRASOV). 

10.SelectaŢi tab General. Aria este afisată acum în kilometrii pătraŢi. 

11.ApăsaŢi Cancel pentru a părăsi fereastra de dialog JudeteImport Properties. 

12.SalvaŢi GeoWorkspace-ul. 

 

1.6. Utilizarea ferestrei de date 

PuteŢi deschide fereastra de date pentru a vizualiza atributele fiecărui element grafic JudeteImport. 

Fereastra de date este o vedere, în format tabelar a atributelor non-grafice ale elementelor grafice. 

 

1.6.1. Utilizarea comenzii Attribute Selection 
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Utilizarea comenzii Attribute Selection permite vizualizarea numai a unui subset de informaŢii pentru clasa 

de elemente selectată. 

1. SelectaŢi Analysis>Attribute Selection. 

2. În fereastra de dialog Attribute Selection, în câmpul Select attribute from selectaŢi clasa de elemente 

JudeteImport din categoria Utilizate frecvent. În câmpul Attributes sînt afisate atributele clasei de 

elemente selectate. 

3. ApăsaŢi butonul Unselect All pentru a deselecta toate atributele. 

4. SelectaŢi numai următoarele attribute: ID, Den_judet, pop_tot, Tempm_anual, Precm_anual si 

Stratm_zapada. 

5. În câmpul Query name păstraŢi denumirea implicită Attribute selection of judeteImport. 

6. ApăsaŢi butonul OK, fără a selecta nici unul din modurile de afisare (în hartă sau în fereastra de date). 

Interogarea este creată fără a fi adusă în legendă. 

 

1.6.2. Deschiderea ferestrei de date  

VeŢi deschide fereastra de date pentru a vizualiza subsetul de atribute selectate anterior. 

1. SelectaŢi Window > New Data Window. 

2. În fereastra de dialog New Data Window, păstraŢi DataWindow1 ca nume pentru această fereastră si din 

Query selectaŢi interogarea Attribute selection of JudeteImport. 

 

3. ApăsaŢi butonul OK. Fereastra de date apare si conŢine câte un rând de date pentru fiecare judeŢ. 

4. Pentru a vedea fereastra hartă si fereastra cu date împreună, selectaŢi Window > Tile Horizontally. 

5. Pentru a afisa judeŢele după nume , selectaŢi capul coloanei Den_judet. Coloana este selectată. 

6. SelectaŢi Data > Sort Ascending sau comanda prescurtată - buton dreapta al mouse-ului Sort Ascending. 

Va avea loc o sortare ascendentă după nume a judeŢelor. 
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7. Pentru a vedea întreaga hartă a României, asiguraŢi-vă că fereastra hartă este activă si selectaŢi View > 

Pan. 

8. Cu cursorul peste hartă, apăsaŢi si ŢineŢi apăsat butonul stâng al mouse-ului si trageŢi mouse-ul peste 

hartă până când aceasta se mută în centrul ferestrei. 

9. ApăsaŢi tasta ESC pentru a părăsi comanda Pan. 

10.SelectaŢi o linie din tabelul din fereastra de date prin clic pe selectorul de linie al rândului. 

ObservaŢi că statul corespunzător atributului selectat în fereastra de date se selectează în fereastra hartă. 

11.Analog, făcând o selecŢie pe un stat din fereastra hartă, se selectează atributul corespunzător în fereastra 

de date. 

 

Aceasta demonstrează că puteŢi folosi fie fereastra hartă, fie cea de date pentru a selecta elemente grafice din 

baza de date. 

12.În fereastra de date faceŢi clic pe butonul selector al tabelei pentru a selecta toate rândurile din fereastra 

de date (colŢul cel mai din stânga după ID) si veŢi observa cum toate judeŢele din fereastra hartă sunt 

selectate. 

 

1.6.3. Actualizările dinamice ale programului GeoMedia Prof pentru întreŢinerea schimbării datelor 

În continuare veŢi vedea cum se realizează actualizările dinamice ale datelor cu GeoMedia Professional. 

1. În fereastra de date, faceŢi clic pe selectorul de rând corespunzător judeŢului ALBA (acest rând conŢine 

atributele atasate judeŢului). În fereastra hartă este selectat judeŢul ALBA. 
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2. AsiguraŢi-vă că vizualizaŢi judeŢul în fereastra hartă. FaceŢi fereastra hartă activă si folosiŢi comanda 

Pan sau Fit All si Zoom in pentru a vizualiza judeŢul ALBA. 

3. În fereastra hartă faceŢi clic oriunde în afara judeŢului ALBA pentru a-l deselectată. 

4. În fereastra de date, defilaŢi printre atribute pentru a vedea coloana Stratm_zapada. 

Valoarea acestei coloane pentru judeŢul ALBA este 30 si pe harta tematică este afisată în aceeasi culoare ca 

judeŢele înconjurătoare. 

5. SchimbaŢi valoarea în fereastra de date de la 35 la 40 făcând clic mouse în coloana Stratm_zapada din 

dreptul judeŢului si tastând noua valoare, 40. 

6. Când terminaŢi de tastat, faceŢi clic în orice alt câmp din alt rând. 

7. PriviŢi fereastra hartă (procesarea poate dura câteva minute) si observaŢi cum s-a actualizat culoarea 

judeŢului reflectând schimbarea. 

Asa cum s-a văzut, hărŢile tematice din GeoMedia Professional se schimbă automat pentru a reflecta 

schimbarea datelor de tip atribut. 

În capitolul care urmează, cum interogările create în GeoMedia Professional sînt salvate doar ca definiŢii.. 

Aceasta înseamnă că în orice moment afisaŢi o interogare, rezultatele vor fi recreate pe baza datelor curente. 

8. ÎnchideŢi fereastra de date. 

9. MaximizaŢi fereastra hartă. 

10.SelectaŢi View > Fit All pentru a face vizibilă toată harta. 

11.ÎnchideŢi harta tematică făcând clic dreapta pe intrarea legendă Judete dupa Stratm_zapada si selectând 

Display Off. 

12.În legendă, mergeŢi pe tabul Groups, selectaŢi intrarea tematică JudeteImport si mutaŢi-o în grupul 

Neutilizate frecvent. 

13.SalvaŢi GeoWorkspace-ul. 
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2.1. Folosirea atributelor funcŢionale 
 

Se poate folosi comanda Functional Attributes pentru rezolvarea diverselor situaŢii; în acest caz se va 

utiliza pentru a crea două noi atribute: SuprafataLim_admin si Densitate_Pop. Se va obŢine suprafata (aria) 

si densitatea populaŢiei pentru câteva limite administrative din judeŢul Brasov. De asemenea veŢi vedea cum 

se pot utiliza rezultatele unui atribut funcŢional ca date de intrare pentru un altul. 

În acest exerciŢiu veŢi crea mai întâi un filtru spaŢial pentru a vedea limitele administrative din judeŢul 

Brasov. Apoi veŢi reafisa clasa de elemente importată mai devreme Lim_adminImport. Apoi veŢi aplica filtrul 

spaŢial clasei de elemente Lim_adminImport pentru a vedea doar limitele din judeŢul Brasov. Ulterior veŢi 

folosi comanda Select Set to Query pentru a alege doar câteva orase din acest stat după care veŢi crea o 

interogare pentru aceste orase care poate fi introdusă în comanda Functional Attributes. În cele din urmă veŢi 

folosi această comandă pentru a crea noi atribute si, de asemenea, veŢi vedea ce se întâmplă cu atributul 

Densitate_Pop când se schimbă datele pentru una din aceste limite. 

 

2.1.1. Definirea unui filtru spaŢial pentru arie 

 

Un filtru spaŢial defineste o arie în fereastra hartă. Când folosiŢi un filtru spaŢial, doar elementele din 

aria definită sunt afisate si accesibile când le adăugaŢi la fereastra hartă. Filtrele spaŢiale sunt opŢionale, dar 

veŢi definiŢi unul pentru a vedea doar limitele administrative din judeŢul Brasov. 

 

1. Din bara de meniu Spatial Filer, selectaŢi butonul Spatial Filter Options . 

Notă: în cazul în care fereastra de dialog Spatial Filter nu este dechisă, o puteŢi activa din Warehouse > 

Spatial Filter.   

2. În bara de meniu Spatial Filter Options, în câmpul Spatial Operator, selectaŢi operatorul Overlap din lista 

derulantă. 

3. PăstraŢi opŢiunea Display Filter selectată. 

OpŢional: ApăsaŢi butonul Style pentru a seta culoarea albastru si grosimea de 2,000 pentru limita filtrului. 

4. ApăsaŢi butonul Ok în fereastra de dialog Spatial Filter Options. 

5. În fereastra hartă, click în interiorul judeŢului Brasov pentru a-l selecta. 

6. În bara de meniu Spatial Filter Options selectaŢi opŢiunea Select Set. 

 

Elementele au fost filtrate în funcŢie de operatorul selectat. 
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Acum veŢi reafisa clasa de elemente Lim_amdinImport în legendă pentru a fi vizibilă si în fereastra hartă. 

7. În legendă, în tabul Display Order, verificaŢi dacă Lim_adminImport este deasupra clasei de elemente 

JudeteImport. 

8. SelectaŢi Lim_adminImport, apăsaŢi buton dreapta mouse si selectaŢi Display On 

Deoarece a fost aplicat filtru pe judeŢul Brasov, elementele din clasa Lim_adminImport sunt afisate numai în 

interiorul si la graniŢa judeŢului. 

2.1.2. Convertirea unei mulŢimi selectate într-o interogare 

 

PuteŢi crea o mulŢime de date selectate si converti aceste elemente selectate într-o interogare folosind 

comanda Select Set to Query. Scopul acestei comenzi este să permită folosirea conŢinutului unei mulŢimi 

selectate ca dată de intrare pentru alte comenzi, cum ar fi etichetarea sau crearea de zone buffer. În acest 

exerciŢiu veŢi plasa câteva limite administrative (Lim_adminImport) într-o mulŢime selectată si apoi o veŢi 

converti într-o interogare. În următorul exerciŢiu veŢi folosi această interogare ca dată de intrare pentru 

comanda Functional Attributes. Înainte de a folosi comanda Select Set to Query, veŢi folosi comanda zoom 

in pe orasele din partea de sud a judeŢului. 

 

1. SelectaŢi View > Zoom > In. 

2. PlasaŢi cursorul imediat deasupra marginii de jos a judeŢului Brasov, asa cum se vede mai jos. 

 

ŢineŢi apăsat clic-stânga mouse si mutaŢi cursorul astfel încât să încadraŢi jumătatea de sud a judeŢului (asa 

cum se vede mai jos). 
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EliberaŢi mouse-ul si imaginea este mărită. 

 

3. ApăsaŢi ESC pentru a iesi din comanda Zoom. Pentru a selecta mai usor limitele administrative, veŢi 

deselecta opŢiunea Locatable pentru judeŢe. 

4. Clic-dreapta pe intrarea legendă JudeteImport si deselectaŢi Locatable Off. 

Acum veŢi selecta câteva limite administrative (Lim_adminImport). 

ŢineŢi apăsată tasta SHIFT, si alegeŢi 9 limite administrative (Lim_adminImport) din partea de sudvest a 

judeŢului Brasov, asa cum se vede mai jos. 
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5. SelectaŢi Analysis > Select Set to Query. 

6. AsiguraŢi-vă că este afisată clasa de elemente Lim_adminImport în câmpul Select features from. 

ObservaŢii cu privire la restricŢiile curente ale acestei comenzi: 

- Interogarea rezultată poate conŢine date numai dintr-o singură clasă de elemente sau interogare din 

mulŢimea selectată. 

- Elementele fără câmpuri cheie nu pot fi procesate. 

7. În câmpul Query name păstraŢi Selection of Lim_adminImport. 

VeŢi afisa rezultatul interogării numai în fereastra hartă. 

8. SelectaŢi opŢiunea Display query in map window si păstraŢi ne selectată opŢiunea Display query in data 

window. 

9. ApăsaŢi butonul Style. 

10.În fereastra de dialog Select Style, selectaŢi butonul Properties. 

11.În fereastra de dialog Style Properties, sub opŢiunea Fill Style, selectaŢi Simple Fill Style. 

12.În partea dreaptă apăsaŢi butonul Color si selectaŢi culoarea verde (53). 

13.AsiguraŢi-vă că în câmpul Translucency este setată valoarea 0. 

14.ApăsaŢi butonul OK în fereastra Style Properties si Select Style. 

15.În fereastra Select Set To Query apăsaŢi butonul Ok. 

 

Interogarea pentru cele nouă limite administrative este creată din mulŢimea selectată si afisată în legendă si în 

fereastra hartă. 

 

2.1.3. Crearea unui atribut funcŢional 

 

VeŢi folosi rezultatele obŢinute anterior – interogarea creată din mulŢimea selectată – ca dată de intrare 

pentru comanda Functional Attributes. VeŢi folosi această comandă pentru a crea 2 noi atribute numai pentru 

aceste 9 limite administrative (Lim_admin) din judeŢul Brasov (de asemenea, la fel de usor puteŢi crea noi 

atribute pentru toate limitele administrative din acest judeŢ). 
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Comanda Functional Attributes afisează fereastra de dialog Functional Attributes. Scopul acestei 

ferestre de dialog este de a permite definirea câmpurilor de valori ca atribute calculate. Fereastra de dialog 

afisează starea funcŢiilor statistice care pot fi aplicate la nivelul fiecărui câmp în parte: funcŢii geometrice ca 

Merge, funcŢii de timp ca Day sau Hour, funcŢii matematice ca Sin sau Log, funcŢii statistice ca Average sau 

Sum si multe altele. În plus, pot fi folosiŢi mai mulŢi operatori – aritmetici, de comparaŢie, logici, Bitwise, 

String Concatenation sau unari. 

În acest exerciŢiu veŢi crea două noi atribute funcŢionale – AriaLim_admin si DensitatePop – pentru 

cele nouă limite administrative. Mai întâi veŢi crea AriaLim_admin si apoi veŢi vedea cum poate fi folosit 

acest nou atribut pentru a crea DensitatePop. Ulterior veŢi vedea ce se întâmplă dacă se schimbă populaŢia 

uneia din limite administrative. 

 

1. SelectaŢi Analysis > Functional Attributes. 

2. În câmpul Add functional attributes for, din lista derulantă deschideŢi Queries si alegeŢi Selection of 

Lim_adminImport. VeŢi crea un nou atribut funcŢional care conŢine aria limitei administrative. 

3. ApăsaŢi New. 

4. În câmpul Functional attribute name, tastaŢi ArieLim_admin. 

5. Din câmpul Categories alegeŢi Geometry. 

6. Din câmpul Functions, clic pe AREA. 

ObservaŢi sintaxa care este afisată în colŢul din stânga-jos al ferestrei de dialog: 

AREA(Geometry;MeasType;UnitOfMeasure). 

7. Dublu-clic pe AREA. Expresia AREA() apare în câmpul Expression . 

8. AsiguraŢi-vă că cursorul este între cele două paranteze de la AREA(). 

9. Din câmpul Attributes, selectaŢi Input.Geometry1 prin dublu-clic. 

Expresia AREA(Input.Geometry1) apare în câmpul Expression. VeŢi adăuga noi parametri pe care funcŢia 

AREA îi cere. 

10.Cu cursorul poziŢionat înainte de parateza din dreapta tastaŢi separatorul (;). 

11.În câmpul Categories, alegeŢi Constants. Apare lista derulantă Constants în următorul câmp. 

12.Din lista derulantă Constants alegeŢi ProjectedMeas prin dublu-clic pe această constantă. 

13.TastaŢi separatorul (;) si tot din lista derulantă Constants, dublu-clic pe constanta SquareKilometer. 

Expresia AREA(Input.Geometry,ProjectedMeas,SquareKilometer) apare în câmpul Expression. 

14.ApăsaŢi Add pentru a creea un nou atribut funcŢional si apoi selectaŢi Close când fereastra de dialog apare 

din nou. 

SunteŢi gata acum să creaŢi un alt atribut funcŢional care să calculeze densitatea populaŢiei. VeŢi folosi 

rezultatul noului atribut funcŢional ArieLim_admin ca input (dată de intrare) pentru atributul DensitatePop. 

15.ApăsaŢi New. Este afisată fereastra de dialog Functional Attribute. 

16.În câmpul Functional attribute name, tastaŢi DensitatePop. 
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Din lista derulantă Attributes observaŢi că sunt afisate toate atributele originale, precum si atributul 

ArieLim_admin pe care tocmai l-aŢi creat, care apare ca Output.ArieLim_admin. 

17.Din câmpul Attributes, selectaŢi Input.Pop_totala prin dublu-click pe el. 

18.SelectaŢi operatorul de împărŢire. 

19.Dublu-clic pe Output.ArieLim_admin din câmpul Attributes. 

Expression Input.Pop_totala/Output.ArieLim_admin apare în câmpul Expression. 

20.ApăsaŢi Add pentru a creea noul atribut funcŢional, după care apăsaŢi Close. 

Ambele atribute funcŢionale create apar în lista Output functional attributes. 

21.În câmpul Query name, schimbaŢi numele în DensitatePop in Lim_adminImport. 

Interogarea va fi afisată atât în fereastra hartă cât si în fereastra de date. 

22.PăstraŢi selectată opŢiunea Display functional attributes in map window, si utilizaŢi numele implicit 

MapWindow1. 

23.PăstraŢi selectată opŢiunea Display functional attributes in data window si numele implicit 

DataWindow1. 

24.SelectaŢi butonul Style situat lângă câmpul Map window name. 

25.În fereastra de dialog Select Style, selectaŢi butonul Properties. 

26.În fereastra de dialog Style Properties, sub opŢiunea Fill Style, selectaŢi Simple Fill Style. 

27.În partea dreaptă apăsaŢi butonul Color si selectaŢi culoarea galben (43). 

28.AsiguraŢi-vă că în câmpul Translucency este setată valoarea 0. 

29.ApăsaŢi butonul OK în fereastra Style Properties si Select Style. 

30.În fereastra Functional Attributes apăsaŢi butonul Ok. 

Apare fereastra de dialog Style Definition. Tab-ul Area Boundary arată culorile, grosimea si stilul liniei care 

înconjoară elementul. 

31.SelectaŢi tab-ul Area Fill. 

32.Din lista derulantă Type selectaŢi Solid. 

33.SelectaŢi butonul Color si alegeŢi culoarea galbenă. 

34.Clic OK în fereastra de dialog Color. 

35.Clic OK în fereastra de dialog Style Definition. 

36.Clic OK în fereastra de dialog Functional Attributes. Fereastra de date apare peste fereastra hartă. 

 

2.1.4. Rezultatele interogării si ale unei schimbări în baza de date 

 

În acest exerciŢiu veŢi vedea rezultatele în fereastra hartă si în fereastra de date si veŢi vedea ce se 

întâmplă cu rezultatele când se schimbă datele. 

 

1. Pentru vizualizarea ferestrei hartă selectaŢi Window >MapWindow1. 
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2. Pentru a vedea atât fereastra hartă cât si cea de date, selectaŢi Window > Tile Horizontally. 

Rezultatele densităŢii populaŢiei sunt afisate în fereastra hartă iar atributele sunt afisate în fereastra de date, 

inclusiv noile atribute funcŢionale AreaLim_UAT si DensitatePop. În ultimele două coloane din fereastra de 

date sunt afisate câmpurile nou create; AreaLim_UAT si DensitatePop. 

Notă: Pentru că aceste coloane sunt read-only, au un fundal mai închis. 

3. Clic în fereastra hartă pentru a o face activă si apoi selectaŢi View > Pan pentru a muta rezultatele noii 

interogări în centrul ferestrei. 

 

4. SelectaŢi cea mai mare limita administrativa din mulŢimea selectată (Zărnesti) în fereastra hartă, si observaŢi 

că DensitateaPop pentru limita administrativă Zărnesti este de aproximativ 135.5 în fereastra de date. 

VeŢi observa în continuare ce se întâmplă dacă se schimbă datele pentru o limita administrativă. MutaŢi 

Lim_adminImport pe primul loc în legendă. 

5. SelectaŢi intrarea Lim_adminImport din tabul Display Order din legendă, si ŢineŢi apăsat mouse-ul până 

o aduceŢi pe primul loc în legendă. Acum veŢi schimba populaŢia pentru o limita administrativă. 

6. Dublu-clic pe prima localitate (limită administrativă) din dreapta (Zărnesti ) sau Edit > Select Set 

Properties. Fereastra de dialog Lim_adminImport Properties este afisată. 

7. SchimbaŢi valoarea câmpului Pop_totala (PopulaŢie) din 26650 în 50000, si apăsaŢi OK. 

ObservaŢi că în fereastra de date valoarea DensitatePop pentru localitatea Zărnesti s-a modificat corespunzător, 

de la aproximativ 135.5 la aproximativ 254.3. 

8. ÎnchideŢi fereastra de date. 

9. MaximizaŢi fereastra hartă. 

10.SelectaŢi View > Fit All pentru a poziŢiona harta în fereastră. 

 

2.1.5. Stergerea filtrului spaŢial 
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Acum puteŢi sterge filtrul spaŢial aplicat judeŢului Brasov. 

 

1. Din bara de meniu Spatial Filer, selectaŢi butonul Remove Filter. 

 Filtrul spaŢial este eliminat. 

2. SelectaŢi intrările din legendă, din tabul Display Order, (Ţinând apăsat CTRL) Lim_adminImport, 

DensitatePop in Lim_UATImport si Selection of Lim_UATImport, clic dreapta mouse si daŢi Display Off. 

3. În tabul Group, mutaŢi cele trei intrări în grupul Neutilizate frecvent. 

 

2.1.6. Denumirea legendei 

 

PuteŢi crea o legendă cu un anumit nume pentru harta Romaniei. Prin această operaŢie se poate folosi 

aceeasi legendă (gata definită si setată) pentru a controla afisarea elementelor grafice într-o altă fereastră hartă, 

presupunând că aveŢi nevoie de multe din elementele din vechea legendă. 

 

1. SelectaŢi Legend > Name Legend. 

2. În câmpul Name, tastaŢi Legenda curs1. 

3. ApăsaŢi butonul OK. 

4. SalvaŢi GeoWorkspace-ul. 
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2. Captura de date 

GeoMedia Professional include un set complet de elemente destinat capturii corecte, precise a datelor cu 

efort minim (fără erori de topologie). De exemplu, funcŢiile de snap pentru raster si vector SmartSnap, 

spargerea automată a vectorilor si posibilitatea menŢinerii coincidenŢei în timpul vectorizării pentru evitarea 

problemelor clasice de topologie, cum ar fi suprapuneri, intersecŢii fără noduri, găuri etc. Suplimentar, când 

sunt localizate erorile, acestea pot fi usor corectate folosind instrumente inteligente pentru plasare si editare, 

cum sunt comenzile trim si extend sau editarea geometriei coincidente. 

În acest paragraf veŢi deschide un GeoWorkspace în care veŢi vectoriza date caracteristice pentru 

staŢiunea de ski. Apoi veŢi realiza o conexiune la un depozit de date (Warehouse) care date vectoriale 

(existente) ale staŢiunii de ski. Aceste date sunt constituite din clase de elemente diferite si trei elemente liniare. 

După ce veŢi schimba clasa de elemente pentru un element grafic, veŢi plasa din coordonate cinci puncte de 

triangulaŢie, aflate într-un fisier text. În final veŢi insera o imagine raster în datele vectoriale. VeŢi 

georeferenŢia (constrânge în coordonate) imaginea raster, aliniind-o astfel cu datele vectoriale. După 

georeferenŢiere veŢi utiliza imaginea rastru pentru a vectoriza elementele grafice. 

Se recomandă copierea celor două fisiere în care se lucrează pentru a putea fi refolosite ulterior:  

Statiune_ski.gws în directorul GeoWorkspaces si Statiune_ski.mdb, în directorul Warehouses . 

 

2.1. Lansarea comenzilor pentru captura de date 

Pentru început deschideŢi GeoWorkspace-ul în care veŢi crea datele. Acest GeoWorkspace conŢine doar câteva 

elemente grafice si clase de elemente pe care le veŢi utiliza pentru început. 

1. LansaŢi GeoMedia Professional, dacă nu rulează încă, si din directorul C:\Curs deschideŢi fisierul 

Statiune_ski.gws. 

Dacă apare o fereastră de dialog Welcome to GeoMedia Professional, selectaŢi butonul Open existing 

GeoWorkspace, după care, din directorul C:\Curs, selectaŢi Statiune_ski.gws. 

sau 

SelectaŢi File> Open GeoWorkspace din bara de meniu, din directorul C:\Curs selectaŢi Statiune_ski.gws. 

GeoWorkspace-ul este deschis si este afisată o fereastră hartă (map window ). 

 

2.1.1. Conectarea la un Warehouse Access existent 

Warehouse-ul Statiune_ski conŢine diferite clase de elemente si câteva elemente grafice care constituie 

punct de început pentru captura datelor. 

 

1. ApăsaŢi pe Warehouse > New Connection. 

Fereastra de dialog New Connection afisează diferitele tipuri de warehouse-uri la care vă puteŢi conecta. 

2. Din lista Connection Type selectaŢi Access. 

3. În câmpul Connection Name, stergeŢi textul curent si tastaŢi Statiune ski. 

4. În câmpul Access Database file apăsaŢi butonul Browse, pentru a selecta fisierul bază de date. 

5. SelectaŢi Statiune_ski .mdb si apoi apăsaŢi butonul Open. 

6. ApăsaŢi butonul Ok în fereastra de dialog New Connection. 

7. Pentru a verifica dacă există conexiunea la warehouse, selectaŢi Warehouse > Connection. 
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Conexiunea Statiune ski trebuie să apară în câmpul Name. 

8. ApăsaŢi butonul Close. 

2.1.2. Adăugarea claselor de elemente grafice 

AduceŢi claselor de elemente din warehouse-ul Statiune_ski în fereastra hartă. 

 

1. SelectaŢi Legend > Add Legend Entry. 

2. În fereastra de dialog Add Legend Entry deschieŢi conexiunea Statiune ski. toate clasele de elemente vor fi 

selectate 

3. BifaŢi caseta de opŢiuni din faŢa conexiunii Statiune ski.                                                                                 

4.  ApăsaŢi butonul OK în fereastra de dialog Add Legend Entry. 

Toate clasele de elemente si etichetele acestora (labels) sunt adăugate în legendă si totodată afisate în fereastra 

hartă (map window). 

5. În legendă, selectaŢi intrarea Lim_admin, click buton dreapta mouse si selectaŢi opŢiunea Display Off, 

după care click buton dreapta mouse si selectaŢi opŢiunea Hide. 

6. AsiguraŢi-vă că fereastra hartă este maximizată. 

7. SelectaŢi View > Fit All pentru a aduce/vizualiza harta în întreaga fereastră hartă. 

 

2.1.3. Setarea culorii pentru modul de selecŢie 

Se setează culoarea pentru modul de selecŢie astfel încât să difere de culorile de afisare a elementelor 

vectoriale. 

 

1. SelectaŢi Tools > Options. 

2. ApăsaŢi tab-ul Map Display. 

3. Dacă culoarea selectată în opŢiunea Select nu este albastru deschis, schimbaŢi culoarea. 

4. Dacă culoarea pentru modul de selecŢie Highlight nu este orange, schimbaŢi-o. 

5. ApăsaŢi butonul OK. 

 

2.1.4. Schimbarea sistemului de coordonate al GeoWorkspace-ului 

VeŢi schimba două setări ale sistemului de coordonate al GeoWorkspace-ului, astfel încât distanŢele si 

ariile să fie afisate în mile, respectiv mile pătrate. 

 

1. SelectaŢi View>GeoWorkspace Coordinate System. 

2. ApăsaŢi tab-ul Units and Formats. 

3. Din câmpul Type, selectaŢi Area. 

4. În câmpul Unit selectaŢi m^2 (metri pătraŢi). 

5. Din câmpul Type, selectaŢi Distance. 

6. În câmpul Unit selectaŢi m (metri). 

7. ApăsaŢi OK în fereastra de dialog GeoWorkspace Coordinate System. 
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2.1.5. Setarea opŢiunilor de afisare a atributelor pentru elementele nou vectorizate 

Se examinează opŢiunea Display Properties dialog for new features (Afisarea proprietăŢilor pentru 

un element nou) din fereastra de dialog Options pentru a vedea a cum se pot introduce atributele pentru un 

element nou vectorizat. 

 

1. SelectaŢi Tools > Options. 

2. ApăsaŢi tabul Map Display. În câmpul Select selectaŢi culoarea verde deschis iar în câmpul Highlight 

selectaŢi culoarea bleu. 

3. ApăsaŢi tab-ul Placement and Editing din fereastra de dialog Options. 

4. AsiguraŢi-vă că opŢiunea Display Properties dialog for new features este selectată. 

5. ApăsaŢi butonul OK în acest câmp. 

Notă: PuteŢi selecta (on) sau deselectă (off) shortcut-ul comenzii Display Properties dialog for new features 

situată în toolbar-ul Options. 

 
Toate opŢiunile din acest toolbar sunt selectate (on) în mod curent, excepŢie făcând opŢiunea Break Linear 

Features, care ar trebui să fie deselectată (off). Această opŢiune va fi discutată detaliat într-o secŢiune viitoare. 

Dacă selectăm una din comenzile de vectorizare sau editare care au ca rezultat crearea unui nou element, 

cum ar fi Insert Feature sau Change Feature Class si opŢiunea Display Properties dialog for new features 

este selectată (on), va fi afisată automat caseta de dialog Feature Properties în care puteŢi introduce valorile 

atributelor la momentul vectorizării. 

Când această opŢiune este deselectată (off) la momentul creării unui element, caseta de dialog Feature 

Properties nu este afisată, deci nu se pot introduce atribute la momentul vectorizării, ci ulterior. 

 

2.1.6. Schimbarea clasei de elemente grafice 

În warehouse, una din străzi a fost incorect clasificată ca Limita. Vom utiliza comanda Change Feature 

Class pentru a corecta această eroare. 

 

1. În fereastra hartă faceŢi dublu clic pe Strada C (pe str, nu pe etichetă-label) pentru a vedea ce atribute are. 

Atributele apar în fereastra de dialog Limita Properties, de unde rezultă că Strada C este clasificată ca Limita. 

2. ApăsaŢi butonul Cancel pentru a părăsi fereastra de dialog Limita Properties. 

3. În fereastra hartă, selectaŢi elementul grafic aflat sub textul Strada C si selectaŢi Edit > Feature > Change 

Feature Class. 

4. În fereastra de dialog Change Feature Class, din lista derulantă a câmpului Target feature class, deschideŢi 

conexiunea Statiune ski si selectaŢi clasa de elemente Strazi. 

5. PăstraŢi selectate opŢiunile Copy values from matching attributes si Delete original feature. 

6. ApăsaŢi butonul OK. 

Apare fereastra de dialog Strazi Properties corespunzătoare elementului reclasificat. 

Fereastra de dialog apare pentru a fi introduse atributele asociate elementului grafic. Oricum, chiar dacă nu ar 

trebui introduse atribute, fereastra de dialog tot ar fi afisată deoarece opŢiunea Display Properties dialog for 

new features este selectată. 
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7. IntroduceŢi valorile atributelor: Strada C pentru Nume, Str pentru Tip, si 3 pentru ID. 

8. ApăsaŢi butonul OK. 

Elementul reprezintă acum o stradă: noile informaŢii despre aceasta sunt înregistrate în baza de date si 

simbologia acestuia se schimbă în concordanŢă cu aceasta. 

9. SalvaŢi GeoWorkspace-ul. 

 

 

2.1.7. Schimbarea stilului de afisare al clasei de elemente Puncte de triangulaŢie. 

VeŢi alege un simbol pentru punctele de triangulaŢie si apoi le veŢi poziŢiona. 

 

1. În legendă, dublu clic pe iconul intrării Puncte_triang. 

2. In fereastra de dialog Legend Entry Properties, apăsaŢi butonul Properties. 

3. În fereastra Style Properties, în câmpul Type, selectaŢi GeoMedia Feature Symbol Files. 

4. În câmpul Source, apăsaŢi butonul Browse si selectaŢi fisierul GISsym.fsm. 

5. În câmpul Name, apăsaŢi butonul Browse si selectaŢi fisierul GISsym.fsm. 

6. din josul lista derulante a câmpului Type, selectaŢi Symbol. 

7. Daca simbolul nu este deja afisat in câmpul Symbol file, apăsaŢi tab-ul Browse pentru a deschide fisierul cu 

simboluri GISsym.fsm. 

8. Din josul listei derulante Symbol selectaŢi Triangle. 

9. ApăsaŢi butonul OK. 

 

2.1.8. Folosirea coordonatelor pentru plasarea punctelor de triangulaŢie 

PoziŢiile celor cinci puncte de triangulaŢie sunt cunoscute din măsurători si sunt stocate intr-un fisier 

text. Punctelor sunt definite prin coordonate în proiecŢie, X si Y. 

VeŢi copia coordonatele acestor puncte din fisierul text in Coordinate display and entry field folosind 

operaŢii de copy/paste. 

Pentru început deselectaŢi (off) opŢiunea Display Properties dialog for new features. Aceasta setare 

va permite sa poziŢionaŢi punctele fără a introduce atributele la momentul iniŢial (introducerea atributelor se 

va face mai târziu). 

 

1. DeselectaŢi Display Properties dialog for new features, direct din toolbar sau din Tools > Options - 

Placement and Editing deselectaŢi Display Properties dialog for new features si apăsaŢi butonul OK. 

##DeselectaŢi capabilitatea de defilare automată a ecranului (când se utilizează comenzi de plasare, editare, 

mutare, sau măsurare a elementelor caracteristice in afara limitei ferestrei harta) prin selectarea Tools > Options 

> SmartLocate. DezactivaŢi Pan map windows automatically. Nu este necesară utilizarea acestei capabilităŢi 

la momentul inserării elementelor grafice. ApăsaŢi butonul OK. 

2. Folosind un editor de texte, cum ar fi Notepad, deschideŢi fisierul Puncte_triang.txt din folderul C:\Curs. 

3. Întorcându-vă in programul GeoMedia Professional, selectaŢi Insert > Feature. 

Apare fereastra de control Insert Feature, corespunzătoare comenzii Insert > Feature. 

 
4. În câmpul Select Feature Class, din conexiunea Statiune ski, selectaŢi clasa de elemente grafice 

Puncte_triang. 

5. În câmpul Placement mode, selectaŢi Orient to geometry. 
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6. În fereastra de control Precision Coordinates, în lista derulantă din câmpul Coordinate display and entry 

options pulldown, deselectaŢi opŢiunea Update coordinates on mouse move. 

 
Este indicat ca acestă opŢiune să fie deselectată în timpul copierii textelor din fisierul text. In caz contrar, 

coordonatele reflectă poziŢia curentă a cursorului. Se recomandă copierea coordonatelor din fisierul text. 

7. AsiguraŢi-vă că ambele opŢiuni Update coordinate on clic si Clear coordinate after enter sunt selectate. 

Dacă meniul derulant este încă afisat, abandonaŢi-l apăsând ESC. 

8. AsiguraŢi-vă că setarea câmpului Current coordinate format (câmpul din stânga opŢiunii tocmai s-a 

dezactivat - off) este Projection+east,+north(m). 

9. Întorcându-vă in fisierul text, copiaŢi prima linie a textului selectând-o si apăsând pe CTRL-C. 

10.Revenind la GeoMedia Professional, în câmpul Coordinate display and entry field selectaŢi întreaga linie 

care conŢine text, apăsaŢi CTRL-V pentru a înlocui acest text cu textul copiat din fisier, si apoi apăsaŢi 

ENTER. 

ParcurgeŢi aceleasi etape pentru poziŢionarea celor patru puncte ramase, utilizând valorile corespunzătoare din 

fisierul text. Cele cinci puncte de triangulaŢie sunt poziŢionate, două pe Strada A si trei pe Strada B. 

 
Dacă vreŢi să faceŢi modificări, stergeŢi unul din puncte selectând Edit > Feature > Delete, apoi 

plasaŢi-l din nou. 

11.SelectaŢi Select tool pentru a părăsi comanda Insert Feature. 

12.ÎnchideŢi fisierul text. 

13.SalvaŢi GeoWorkspace-ul. 

 

2.1.9. Inserarea unei imagini Raster 
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In GeoMedia Professional captura datelor vectoriale se face cu usurinŢă, deoarece programul permite 

folosirea imaginilor raster georeferenŢiate ca fundal si a instrumentelor (multiple) de vectorizare. Pe imaginile 

raster snap-urile la raster sunt instrumente disponibile, si pot fi utilizate împreună cu snap-urile la vectori in 

procesul de vectorizare. După cum veŢi vedea, mutarea cursorului determina apariŢia simbolurilor 

corespunzătoarea tipurilor de snap, fără a fi necesara efectuarea comenzilor de zoom in asupra datelor de lucru. 

 

1. SelectaŢi Insert > Interactive Image. 

2. ApăsaŢi butonul Browse. 

3. DeschideŢi imaginea raster Harta_detaliu.rle din directorul C:\Curs, apăsând butonul Open. 

4. SelectaŢi, in câmpul Warehouse conexiunea Statiune ski. 

5. În câmpul Feature class tastaŢi numele noii clase de elemente: ImagDetaliu (fără spaŢii). 

6. ApăsaŢi OK. 

Cursorul devine cross-hair iar la prompt-er apare mesajul Press and drag to define image size and scale. 

Nota: PuteŢi muta legenda in alta parte a ecranului sau să o închideŢi temporar. 

7. PlasaŢi cursorul in interiorul ferestrei hartă, apăsaŢi butonul stâng al mouse-ului si trageŢi de cursor pentru a 

defini o arie rectangulara între cele cinci puncte de triangulaŢie. Apoi eliberaŢi butonul mouse-ului. 

 
Imaginea este poziŢionată în fereastra harta. 

Nota: 

- Dacă imaginea este prea mică pentru a putea încadra cele cinci puncte ( L1-L5; este foarte important sa vedeŢi 

etichetele acestora), puteŢi să stergeŢi imaginea - selectaŢi intrarea in legenda Legend după care apăsaŢi 

DELETE. Apoi poziŢionaŢi imaginea din nou. 

- Daca imaginea este suficient de mare pentru a citi conŢinutul, dar nu este bine localizată pe ecran (de 

exemplu, acoperă unul din cele cinci puncte), puteŢi muta imaginea. Pentru aceasta, selectaŢi imaginea apoi 
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selectaŢi Edit > Geometry > Move pentru a muta imaginea in fereastra harta astfel încât să puteŢi vizualizaŢi 

cele doua imagini si cele cinci puncte. UtilizaŢi comenzile Pan si Zoom daca este necesar. 

 

2.1.10.Schimbarea Culorii Imaginii Raster 

OperaŢia de schimbare a culorii imaginii raster intr-o culoare diferita de negru este foarte usoară. 

Schimbarea culorii (intr-una mai deschisă) se impune in procesul de vectorizare pentru mai buna vizualizare a 

instrumentelor de snap (descrise intr-o secŢiune viitoare). 

 

1. Dublu clic in legenda pe icon-ul intrării ImagDetaliu. 

2. In caseta de dialog Legend Entry Properties, selectaŢi Properties. 

3. În partea de jos a ferestrei Style Properties, în zona Binary, în câmpul Foreground color, selectaŢi culoarea 

gri deschis. Nu utilizaŢi aceleasi culori pe care le-aŢi utilizat pentru celelalte obiecte (orange, albastru deschis). 

4. PăstraŢi neselectate opŢiunile Invert Image si Transparent. 

5. ApăsaŢi butonul OK in toate casetele de dialog.  Culoarea imaginii raster este schimbata. 

6. SalvaŢi GeoWorkspace-ul. 

 

2.1.11.GeoreferenŢierea Imaginii Raster 

Dacă imaginea a fost plasată corect, in fereastra hartă, puteŢi trece la georeferenŢierea (constrângerea în 

coordonate) acesteia. Precizia poziŢionării punctelor este realizata folosind comanda Image Registration si 

opŢiunile de snap la raster si vector (pentru ghidare). 

 

1. AsiguraŢi-vă că vedeŢi toolbar-ul SmartSnap.  

 
Nota: Dacă nu-l vedeŢi, îl puteŢi afisa selectând opŢiunea SmartSnap din View > Toolbars, apoi apăsaŢi 

butonul OK. In acest toolbar, sunt selectate (on) doar cinci din snap-uri, cele din stânga, snap-urile la vector si 

sunt deselectate (off) cele din dreapta, snap-urile la rastru. 

În acest exerciŢiu doar snap-urile Origin (vector) si Intersection (raster) vor fi utilizate 

2. SelectaŢi imaginea care urmează a fi poziŢionată printr-un simplu clic (clic pe imagine). 

3. Cu imaginea selectată (click în fereastra hartă, pe imaginea rastru), selectaŢi Tools > Image Registration. 

4. In fereastra de dialog Registrations, apăsaŢi tab-ul New. 

5. Se deschide fereastra New Image Registration. 

Fereastra New Image Registration afisează pentru fiecare pereche de puncte de control erorile 

obŢinute în urma georeferenŢierii. Suplimentar oferă butoane pentru introducerea punctelor de control. 

6. SelectaŢi Add Points. Acest buton permite introducerea perechilor de puncte prin clic in fereastra harta. 

7. La mesajul Clic to place source control point 1 care apare la prompt-er, clic pe punctul L1 din imaginea 

raster. 

8. PlasaŢi mouse-ul in centrul punctului. Când apare simbolul snap-ului Intersection apăsaŢi butonul stâng al 

mouse-ului. Primul punctul 1 este plasat pe imaginea rastru. 

9. La mesajul Clic to place target control point 1 care apare la prompt-er, plasaŢi cursorul in punctul 

corespunzător lui L1 pe vector. Când apare simbolul snap-ului Origin, ca in figura de mai jos, clic pe butonul 

mouse-ului. 
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Primul punct 1 este plasat pe datele vector. 

10.La mesajul Clic to place source control point 2 care apare la prompt-er, clic pe punctul L2 din imaginea 

raster. 

11.La mesajul Clic to place target control point 2 care apare la prompt-er, clic pe punctul L2 pe vector. 

12.ContinuaŢi poziŢionarea punctelor control sursa si control destinatie L3, L4 si L5 din imaginea raster 

respectiv vector. 

13.Dublu clic pe butonul din stânga al mouse-ului pentru a finaliza operaŢia. 

Este afisată fereastra de dialog New Image Registration care conŢine perechile de puncte de control create. 

Sunt calculate si afisate erorile reziduale. 

14.In câmpul Name al acestei ferestre de dialog, înlocuiŢi textul existent cu Imagine calibrata. 

15.ApăsaŢi tab-ul Register. 

Imaginea este georeferenŢiată (calibrată, constrânsă in coordonate), ca in figura de mai jos. 
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Nota: Dacă imaginea nu este georeferenŢiată corect, alternativ, puteŢi sterge înregistrarea curentă si selecta una 

existentă cu care să recalibraŢi imaginea. Pentru aceasta, selectaŢi înregistrarea curentă, Imagine calibrata, din 

fereastra de dialog Registrations si apăsaŢi Delete. Apoi, selectaŢi imaginea georeferenŢiată existentă, Image 

Registration 1 si apăsaŢi Register. 

16.SelectaŢi View > Fit All. 

17. In legendă, în tabul Dispaly Order, selectaŢi intrarea ImagDetaliu (imaginea rastru) si mutaŢi-o pe ultima 

poziŢie din legendă pentru a avea cea mai scăzută prioritate de afisare. 

Celelalte intrări în legendă au acum prioritate de afisare. 

18.SalvaŢi GeoWorkspace-ul. 
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4.2. OperaŢii necesare pentru conversia datelor raster în vector si editarea acestora 

In această secŢiune, veŢi utiliza imaginea raster georeferenŢiată în secŢiunea anterioară pentru 

începerea vectorizării. Cele trei străzi si cele cinci puncte de triangulaŢie pe care le vedeŢi in GeoWorkspace, 

sunt date vector existente. VeŢi utiliza imaginea raster pentru a modifica strada, a adăuga clădiri si pentru 

vectorizarea unui element grafic limită. Pentru aceasta veŢi trasa aceste componente pe imaginea raster prin 

vectorizare, transformându-le astfel în date vectoriale. ŢineŢi minte ca folosiŢi imaginea raster ca un fundal 

peste care veŢi trasa cu exactitate toate liniile. 

GeoMedia Professional include cinci tipuri de snap-uri pentru vectori si sase tipuri snap-uri pentru raster. 

Aceste instrumente le puteŢi utiliza când poziŢionaŢi sau editaŢi geometria. Snap-urile care apar in toolbar-ul 

(bara de instrumente) SmartSnap, sunt descrise în cele ce urmează: 

 
 

 
 

Nota: In timpul poziŢionării sau editării, un punct este poziŢionat la locaŢia indicată când apare simbolul 

corespunzător snap-ului. 

Dacă mai mult de un simbol snap apare la locaŢia cursorului, cel cu prioritatea cea mai mare are 

precedenta. Prioritatea este de la stânga la dreapta în toolbar. 

Pentru a seta toleranta snap-urilor pentru vectori si raster utilizaŢi Tools > SmartSnap Tolerances. 
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IMPORTANT: Cele sase facilităŢi raster snap (Intersection, End of line, Corner, Open Symbol, Closed Symbol, 

and Center) pot fi folosite doar când imaginea raster este in format binary (formatul imaginii raster utilizata in 

acest exerciŢiu). 

 

4.2.1. Schimbarea stilului de afisare a claselor de elemente grafice: Strazi, Limite si Cladiri. 

VeŢi vectoriza străzi, limite si clădiri utilizând imaginea raster ca fundal. Pentru ca elementele 

vectorizate sa apară peste imaginea raster trebuie sa schimbaŢi stilul de afisare al clasei de elemente grafice. 

 

1. Dublu clic in legenda pe intrarea clasei de elemente grafice Strazi. 

2. In fereastra de dialog Legend Entry Properties, apăsaŢi butonul Color si schimbaŢi culoarea clasei de 

elemente grafice Strazi in maro. 

3. ApăsaŢi OK in fereastra de dialog. 

4. Dublu clic in legenda pe intrarea clasei de elemente grafice Limite. 

5. Pentru clasa de elemente Limite, alegeŢi culoarea verde. 

6. ApăsaŢi OK in fereastra de dialog. 

7. Dublu clic in legenda pe intrarea clasei de elemente grafice Cladiri. 

8. Pentru clasa de elemente Cladiri, în câmpul Boundary, alegeŢi culoarea verde închis. 

9. ApăsaŢi butonul OK in fereastra de dialog. 

10.SalvaŢi GeoWorkspace-ul. 

 

4.2.2. Setarea opŢiunii Copy Attributes from Previous Feature Option (copierea atributelor de la un 

element creat anterior) 

VeŢi examina una din opŢiunile care apar in fereastra de dialog Options, Copy attributes from previous 

feature (copierea atributelor de la un element creat anterior). 

ObservaŢi cum sunt salvate aceleasi informaŢii ale atributelor intrări de fiecare data când poziŢionaŢi 

mai multe elemente cu atribute similare. 

 

1. SelectaŢi Tools > Options. 

2. In fereastra de dialog Options selectaŢi tab-ul Placement and Editing. 

3. AsiguraŢi-vă ca opŢiunea Copy attributes from previous feature este selectată. 

4. ApăsaŢi butonul OK in aceasta fereastra de dialog. 

Când opŢiunea Copy attributes from previous feature este selectată si poziŢionaŢi succesiv două sau 

mai multe elemente din aceeasi clasă de elemente folosind fie Insert Feature, Insert Text, sau Interactive 

Label - valorile atributelor primului element sunt copiate în înregistrările celui de-al doilea element. Dacă 

opŢiunea Display Properties dialog for new features este deselectată, aceste valori apar în fereastra de dialog 

Properties succesiv, de fiecare dată când elementul este poziŢionat, într-u cât valorile atributelor precedente 

sunt copiate, le puteŢi folosi sau edita ori de câte ori este necesar. Aceasta opŢiune este folosită în special când 

poziŢionaŢi mai multe elemente ce au atribute asemănătoare. 

În următorul exerciŢiu, veŢi vedea un exemplu de utilizare a acestor opŢiuni. 

 

4.2.3.Adăugarea clădirilor din imaginea raster în hartă 

Pentru început, veŢi adăuga câteva clădiri din imaginea raster în hartă. Ulterior, veŢi modifica aceste 

clădiri, folosind instrumentele Split si Copy Parallel 
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1. In toolbar-ul (bara de instrumente) SmartSnap, selectaŢi toate instrumentele de snap, atât pentru vectori cat 

si pentru raster cu excepŢia Center Snap (raster).              

2. SelectaŢi opŢiunea Display properties dialog for new features, fie din toolbar (bara de instrumente) fie 

selectând tab-ul Placement and Editing din Tools > Options. 

3. SelectaŢi Insert > Feature. 

4. SelectaŢi clasa de elemente grafice Cladiri din fereastra de control caracteristică comenzii Insert Feature 

Butonul de control Area selectat va arata ca puteŢi insera un element de tip arie. 

Grupul de butoane de control indică tipurile de geometrii utilizate la vectorizare. 

5. Din lista derulantă Placement Mode, selectaŢi Place by rotate rectangle. 

Dacă utilizaŢi acest tip de poziŢionare, puteŢi amplasa o serie de dreptunghiuri rotite. 

6. Folosind comanda Zoom in în jurul grupului de construcŢii numerotate din imaginea raster afisarea va fi 

efectuata asemănător ca in figura de mai jos. ApăsaŢi tasta ESC pentru a reveni la comanda Insert Feature. 

 

7. La mesajul Clic to place first point for Cladiri, poziŢionaŢi cursorul in apropierea coltului stânga sus al 

cladirii 1 si faceŢi clic pentru a poziŢiona primul punct. 

Nota: La acest nivel de detaliere (zoom in), este usor să aproximaŢi punctele fără a urmări fiecare simbol snap 

care este afisat când poziŢionaŢi fiecare punct. Snap-urile sunt foarte utile când efectuaŢi operaŢii de zoom out. 

8. La mesajul Clic to place next point, poziŢionaŢi cursorul în apropierea colŢului dreapta sus (al aceleiasi 

clădiri si faceŢi clic pentru a poziŢiona al doilea punct. 

Nota: Dacă în timpul vectorizării trebuie să faceŢi o rectificare, puteŢi da un pas in urmă prin apăsarea tastei 

BACKSPACE. PuteŢi de asemenea să folosiŢi comanda UNDO. 

Nu fiŢi îngrijoraŢi dacă rezultatele vectorizării nu urmăresc exact liniile de pe imaginea raster. 

9. PlasaŢi si cel de al trei-lea punct în colŢul adiacent. 

ConstrucŢia 1 a fost plasată si este afisată fereastra de dialog Cladiri Properties 

10. TastaŢi următoarele valori pentru atribute: Cladire 1 pentru Nume, Cabana de ski pentru Destinatie si 221 

pentru Numar (identificatorul clădirii). 

11. ApăsaŢi butonul OK. 

12. FolosiŢi acelasi proces pentru a Cladire 2. ÎncepeŢi prin revenirea la Point by Point (prin selectarea 

opŢiunii din toolbar sau prin apăsarea tastei L), poziŢionaŢi cele două puncte de început si treceŢi pe Angle 

Placement pentru a plasa ultimele două puncte. 
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După vectorizarea celei de-a doua clădiri Cladire 2, este afisată fereastra de dialog Cladiri Properties. 

Deoarece a fost selectată opŢiunea Copy Attributes from Previous Feature, valorile atributelor sunt copiate de la 

elementul vectorizat înainte, Cladire 1. 

13.TastaŢi următoarele valori pentru atribute: Cladire 2 pentru Nume, Cabana de ski pentru Destinatie si 222 

pentru Numar (identificatorul clădirii). Primele două clădiri au fost inserate. 

14.SalvaŢi the GeoWorkspace-ul. 

 

4.2.4.Folosirea comenzilor Undo si Redo. 

Presupunem ca aŢi făcut o eroare de poziŢionare/editare a unui element si vreŢi să anulaŢi cu undo sau 

redo un element pe care l-aŢi poziŢionat. 

 

1. SelectaŢi Tools > Options. 

2. SelectaŢi tab-ul Placement and Editing. 

ObservaŢi fereastra Undo a acestui tab. Această fereastră controlează setările pentru comenzile Undo/Redo. 

3. AsiguraŢi-vă că opŢiunea Undo este selectată. 

Această opŢiune activează comanda Undo, care vă permite să anulaŢi rezultatele comenzilor de poziŢionare si 

editare din sesiunea curentă. 

4. AsiguraŢi-vă că opŢiunea Limit undo operations este selectată si în câmpul Number este numărul 5. 

Aceasta opŢiune permite setarea limitei numărului de operaŢii ce pot fi anulate sau returnate. Aceasta nu este o 

limită maximă (sunteŢi limitat doar de memoria calculatorului). 

5. ApăsaŢi OK in fereastra de dialog Options. 

VeŢi sti să anulaŢi operaŢia de poziŢionare a clădirilor folosind Undo comanda si apoi folosiŢi Redo pentru a 

readuce clădirile. 

6. SelectaŢi Edit > Undo Insert Feature.  Clădirea 2 este stearsă. 

7. SelectaŢi din nou Edit > Undo Insert Feature.  Clădirea 1 este stearsă. 

VeŢi sti să folosiŢi comanda Redo pentru reafisarea clădirilor. 

8. SelectaŢi Edit > Redo Insert Feature.   Clădirea 1 este readusă în imagine. 

9. SelectaŢi din nou Edit > Redo Insert Feature.  Clădirea 2 este readusă în imagine. 

10.ÎncercaŢi să selectaŢi pentru a treia oara Edit > Redo Insert Feature. 

Comanda Redo este dezactivata deoarece cele doua operaŢii de anulare au fost reexecutate. 

11.ContinuaŢi vectorizarea, folosind procedeul descris mai sus, pentru a plasa cladirea 3. 

După vectorizarea celei de-a treia clădiri Cladire 3, este afisată fereastra de dialog Cladiri Properties. 

Deoarece opŢiunea Copy Attributes from Previous Feature a fost selectată, valorile atributelor sunt copiate 

de la elementul vectorizat înainte, Cladire 2. 
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12.TastaŢi următoarele valori pentru atribute: Cladire 3 pentru Nume, Cabana de ski pentru Destinatie si 223 

pentru Numar (identificatorul clădirii). 

13.FolosiŢi acelasi procedeu pentru a vectoriza clădirea 4. 

14.În caseta Cladiri Properties, tastaŢi următoarele valori pentru atribute: Cladire 4 pentru Nume, Cabana de 

ski pentru Destinatie si 224 pentru Numar (identificatorul clădirii). 

15.SalvaŢi GeoWorkspace-ul. RămâneŢi în Insert Feature pentru următorul exerciŢiu. 

 

4.2.5.Vectorizarea primului element din clasa Limite – Limita1 

FolosiŢi Insert Feature pentru plasarea primei părŢi din elementul Limite. Pentru vectorizare se 

foloseste ca suport (fundal) imaginea raster. 

 

1. AsiguraŢi-vă că opŢiunea Display Properties dialog for new features este încă selectată, fie privind 

toolbar-ul fie selectând Tools > Options apoi apăsând pe tab-ul Placement and Editing.  

2. In caseta de control a comenzii Insert Feature, selectaŢi clasa de elemente grafice Limite. 

3. SelectaŢi View > Fit All. ÎncepeŢi vectorizarea elementului Limita 1 – start (1). 

4. VectorizaŢi Limita 1 urmărind tabelele de mai jos. Urmărind mesajele veŢi plasa cursorul in apropierea 

locaŢiei cu o toleranŢă faŢă de punctele numerotate ale imaginii raster (sau vector daca sunt indicate) conform 

specificaŢiei de mai jos. Când apare simbolul corect al snap-ului faceŢi clic stânga pe butonul mouse-lui. 

PoziŢionaŢi prima parte a elementului Limite utilizând opŢiunea Point by Point din câmpul Placement Mode. 

 

Nu opriŢi procesul de vectorizare. VeŢi trasa următoarea parte a limitei ca un arc. 

5. PoziŢionaŢi următoarea parte a limitei ca un arc. 

6. Din câmpul Placement Mode, selectaŢi opŢiunea Arc by start, end, point on edge, fie apăsând butonul din 

toolbar fie apăsând tasta A. 

7. ApăsaŢi buton dreapta mouse si deselectaŢi opŢiunea Arc Tangency Constraint. 

8. VectorizaŢi arcul după cum urmează: 
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Arcul este poziŢionat. 

Nota: Este usor să poziŢionaŢi Arc by start, End, point on edge când deja stiŢi punctele de început, sfârsit 

(cum aŢi făcut in acest caz folosind ca suport imaginea raster). Se poate crea un arc mai usor folosind opŢiunea 

Arc by start, point on edge, end. 

9. SchimbaŢi pe Point by Point prin apăsarea butonului corespunzător fie apăsând tasta L. 

10.VectorizaŢi următoarele puncte după cum urmează. 

 

11.DefinitivaŢi vectorizarea elementului prin dublu clic sau clic ALT sau prin apăsarea butonului dreapta al 

mouse-ului si apoi selectarea End Feature. 

12.In fereastra de dialog Limite Properties, tastaŢi următoarele valori: Limita 1 pentru Nume, Mediu pentru 

Evaluare si 12 pentru Numar. 

13.ApăsaŢi butonul OK. 

14.ApăsaŢi ESC pentru părăsi comanda Insert Feature. 

O parte a elementului Limita 1 este creată, de la punctul 1 la punctul 10. 

15.SalvaŢi GeoWorkspace-ul. 

4.2.6. Setarea opŢiunii Break Linear Features. 

OpŢiunea Break linear features din fereastra de dialog Options vă permite să spargeŢi un element in 

două (la momentul plasării unui nou element grafic in apropierea altuia). Dacă activaŢi această opŢiune, puteŢi 

specifica clar cum doriŢi să apară ruptura: la liniile coincidente ale elementelor grafice sau doar a celor din 

aceeasi clasă de elemente. 

 

1. SelectaŢi Tools > Options. 

2. SelectaŢi tab-ul Placement and Editing. 

3. SelectaŢi Break linear features. OpŢiunea Break all feature este de asemenea selectată. 

4. ApăsaŢi butonul OK pentru a părăsi fereastra de dialog. 

Nota: Ca opŢiune, puteŢi deschide sau închide această setare din toolbar-ul Options. 

 

4.2.7.Extinderea unui element grafic 



52 

FolosiŢi comanda Extend to Intersection pentru a extinde Strada C astfel încât aceasta să se 

intersecteze cu Strada A prin specificarea unui singur punct. 

AdiŢional, dacă selectaŢi opŢiunea Break linear features, când se execută operaŢiunea Extend to 

Intersection, Strada A va fi spartă în două străzi. 

 

1. AranjaŢi imaginea in asa fel încât să vedeŢi clar porŢiunea cuprinsă intre punctele 15, 17 si 18. 

 

2. SelectaŢi Edit > Geometry > Extend to Intersection. 

3. La mesajul Select a feature to be extended, plasaŢi cursorul peste punctul 15 al elementului Strada C . 

După o scurtă pauză spuneŢi sistemului că vreŢi să extindeŢi această linie, segmentul de linie ce va fi extins 

este selectat. 

  

4. Când segmentul de linie ce urmează a fi extins este selectat, executaŢi clic pentru a accepta operaŢia. 

Strada C este extinsă până la Strada A, iar Strada A este spartă în două străzi. Fereastra de dialog Strazi 

Properties este afisată pentru cea de-a doua stradă (strada nou creată). 
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5. TastaŢi următoarele valori ale atributelor pentru primul segment (segmentul din stânga): Strada A pentru 

Nume, Str pentru Tip, si 16 pentru Numar. 

6. TastaŢi următoarele valori ale atributelor pentru primul segment (segmentul din dreapta): Strada A2 pentru 

Nume, Str pentru Tip, si 17 pentru Numar. 

7. ApăsaŢi butonul OK. Noile străzi sunt înregistrate în baza de date. 

8. ApăsaŢi tasta ESC pentru părăsi comanda Extend to Intersection. 

9. AsiguraŢi-vă că instrumentul Select este selectat. MutaŢi cursorul deasupra străzii Strada A apoi deasupra 

străzii Strada A2. Deoarece acestea sunt acum elemente diferite, se vor selecta separat. 

10.DeselectaŢi opŢiunea Break linear features fie din toolbar, fie selectând Tools > Options si dezactivând 

aceasta opŢiune din tab-ul Placement and Editing. 

11. SalvaŢi GeoWorkspace-ul. 


