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 Linia de comandă (command line):

 Metoda tradiţională de introducere a comenzilor în AutoCAD, prin tipărirea 
acestora la promptul "Command:" 

 Toate comenzile pot fi introduse din linia de comandă. Chiar şi atunci când 
sunt introduse din meniu sau bare de unelte, comenzile sunt preluate de 
linia de comandă.

 Interacţiunea dintre utilizator şi program are loc prin mesajele din linia de 
comandă. 

 Unele comenzi au nevoie de diverse opţiuni (parametri) pe care utilizatorul 
trebuie să le introducă în linia de comandă.

 Linia de comandă conţine în mod implicit trei rânduri. Apăsând tasta F2 se 
deschide o fereastră text care conţine o istorie a comenzilor introduse în 
sesiunea curentă de lucru

 Bara de stare:

 Afişează coordonatele curente în colţul stânga-jos a ecranului

 Conţine câteva butoane care afişează/modifică câteva setări ale desenului

CAPITOLUL II – COMENZI ȘI PREGĂTIREA 
SPAȚIULUI PENTRU DESEN

§ 2.1 Introducerea comenzilor
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 Introducerea comenzilor din linia de 
comandă:

 Forma lungă: metoda tradiţională, prin 
tastarea comenzii (ex. line)

 forma scurtă [alias]: poate fi foarte eficientă 
(ex. l)

 Introducerea comenzilor din meniu:

 Rulează o comandă (pentru o comandă 
simplă). Exemplu: Draw>Line

 deschide o casetă de dialog (atunci când 
comanda este urmată de …   )

 deschide un submeniu 

 Introducerea comenzilor din bara de 
unelte:

§ 2.1 Introducerea comenzilor
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 Linia de comandă:

 Comanda se introduce în linia de comandă, urmată de ENTER sau SPACE

§ 2.1 Introducerea comenzilor

 Formatul opţiunilor unei comenzi:

 SPACE, sau click pe butonul dreapta de la mouse

 Comenzi de editare (DEL, backspace, săgeţi, etc.)

 Reutilizarea comenzilor: tastele săgeţi sus şi jos

 vizualizarea istoriei comenzilor : tasta F2 (deschide fereastra de text)

OBS. Linia de comandă trebuie urmărită permanent:
- Current instruction or [options] <current value>:

- Pentru a selecta o opţiune, tastaţi literele evidenţiate
- Pentru a accepta valoarea curentă (implicită), apăsaţi enter

 Repetarea unei comenzi:
 apăsaţi enter (sau spaţiu, sau click pe butonul dreapta de la mouse) penru a repeta 

ultima comandă

 tastaţi MULTIPLE înainte de introducerea unei comenzi pentru repetarea de câteva ori 
a acelei comenzi

 Anularea unei comenzi: tasta ESC
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 Undo şi Redo:

 AutoCAD înregistrează toate comenzile care au fost executate în sesiunea 
curentă de lucru, iar acestea pot fi derulate

§ 2.1 Introducerea comenzilor

 UNDO - opţiuni: Auto/Control/BEgin/End/Mark/Back/<Number>
 Number: numărul de operaţii pe care să le deruleze

 Auto (On/Off): Se aplică comenzilor din meniuri care execută o serie de comenzi. On -
este derulată întreaga serie de comenzi; Off - derularea comenzilor este efectuată pas 
cu pas.

 Control (All/None/One): All - o funcţionalitate totală a comenzii UNDO; None -
dezactivează comanda UNDO; One - poate fi derulat doar un singur pas

 Begin şi End: grupează o secvenţă de comenzi într-un grup care poate fi derulat în bloc

 Mark şi Back: marchează o stare a desenului, până la care se poate derula mai târziu 
folosind opţiunea Back

 REDO:
 reface efectul unei comenzi U sau UNDO precedente

 poate fi folosită o singură dată

 trebuie să urmeze imediat unei comenzi U sau UNDO
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 Comenzi transparente:

 Pentru ca o comandă să fie apelată în mod transparent în linia de 
comandă, aceasta trebuie să fie precedată de un apostrof

 Comenzi introduse în cadrul unei alte comenzi active

 Exemplu: zoom (permite schimbarea modului de vizualizare a desenului, 
poate fi folosită transparent în timp ce este activă o comandă de desenare)

 Comenzile care suportă transparenţa şi sunt accesate din barele de unelte 
sunt transparente automat

§ 2.1 Introducerea comenzilor

Command: l

LINE From point:

To point: 'zoom

>>All/Center/Dynamic/Extents/Previous/Scale(X/XP)/Window/<Realtime>:

>>Press Esc or  exit, or right-click to activate pop-up menu.

Resuming LINE command.
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 Ajutorul: în mod uzual prin tasta F1 sau Help>Help (din meniu)

 Contents: ajutor organizat după subiect

 User's Guide: ajutor de tip "cum să..."

 Command Reference: informaţii asupra comenzilor şi a variabilelor de sistem

 Index: o listă alfabetică a subiectelor

 Search: căutarea unor cuvinte-cheie în tot materialul disponibil

 Favorites: folosită pentru colectarea unor subiecte favorite

 Ask Me: formularea unei întrebări în limbaj normal

§ 2.2 Comenzi - Utilizarea ajutorului (Help)

 Organizarea unui subiect:

 Concepts: o descriere de ansamblu a problemei

 Procedures: descrierea procedurilor de realizare a problemei

 Commands: comenzi legate de subiect
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 Se pot obţine informaţii despre o comandă specifică apăsând tasta F1 
atunci când comanda este activă

§ 2.2 Comenzi - Utilizarea ajutorului (Help)
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 Coordonatele sunt folosite pentru specificare punctelor în AutoCAD, 
şi sunt specificate faţă de sistemul de coordonate utilizator

 Sistemul de coordonate global - World Coordinate System (WCS) 
este sistemul de coordonate implicit al AutoCAD

 Sistemul de coordonate utilizator - User Coordinate System (UCS) 
este un sistem Cartezian XYZ modificat de utilizator

 Pentru desene în plan, trebuie specificate doar coordonatele X şi Y

 Unităţile de măsură: AutoCAD nu are unităţi de măsură -
utilizatorul decide dacă valorile utilizate sunt mm sau km sau ţoli. 

 Coordonatele pot fi introduse folosind mouse-ul, sau de la tastatură

 În AutoCAD desenul se realizează de obicei la scara 1:1 (o clădire de 
12x10m va fi desenată cu dimensiunile de 12x10m)

§ 2.3 Utilizarea coordonatelor
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Command: line

From point: –2,1

To point: 3,4

§ 2.3 Utilizarea coordonatelor

 Coordonate absolute (x,y): sunt 
specificate în raport cu UCS-ul curent.
exemplu: pentru a desena o linie de la 
punctul (-2,1) la (3,4):

 Coordonate relative  (@x,y): sunt 
specificate faţă de ultimul punct introdus.
exemplu: pentru a desena o linie de la 
punctul (-2,1) la un punct care se află 
la 5 unităţi în direcţia pozitivă a axei X:

Command: line

From point: –2,1

To point: @5,0

Introducerea coordonatelor carteziene (de la tastatură)
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§ 2.3 Utilizarea coordonatelor

 Setările implicite pentru măsurarea
unghiurilor:
 Unghiurile sunt exprimate în grade

 Zero grade corespund axei pozitive X

 Unghiurile sunt pozitive în sens anti-orar

 Coordonate absolute (distance<angle): 
specificate faţă de originea UCS.
exemplu: Command:  line

From point:  0,0

To point:  4<120

To point:  5<30 

Introducerea coordonatelor polare (de la tastatură)

 Coordonate relative (@distance<angle): 
specificate faţă de ultimul punct introdus.           
Exemplu:

To point: @3<45 
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§ 2.3 Utilizarea coordonatelor

 Afişarea coordonatelor ajută la editarea desenelor, pentru a cunoaşte 
coordonatele curente, sau distanţa şi direcţia în care se mişcă cursorul

 Trei moduri de afişare a coordonatelor:
 absolute dinamice: coordonatele X,Y,Z sunt 

actualizate cu mişcarea mouse-ului.

 absolute statice: coordonatele X,Y,Z sunt 

actualizate numai la specificarea unui punct.

 relative dinamice: actualizează distanţa relativă

(distanţă < unghi, Z) cu mişcarea cursorului. 

Această opţiune este disponibilă numai la desenarea 

obiectelor care necesită specificarea mai multor puncte.

Afișarea coordonatelor

 Schimbarea modului de afişare a coordonatelor:
 tasta F6

 click pe suprafaţa de afişare a coordonatelor în bara de stare

 combinaţia de taste ctrl+D
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§ 2.4 Modul ORTHO, SNAP, GRID, POLAR TRACKING

 Introducerea directă a distanţelor: după specificarea unui punct, se 
indică direcţia dorită cu mause-ul şi se specifică prin tastare distanţa 
dorită. Deosebit de util împreună cu modul ortogonal şi cu urmărirea 
polară (polar tracking)

 Modul ortogonal
 Restricţionează mişcarea cursorului la direcţiile orizontală şi verticală (în raport cu UCS-

ul curent)

 Activate dezactivate prin:

 tasta F8

 butonul ORTHO din bara de stare

 comanda ORTHO

Modul ORTHO

OBS. Modul ORTHO şi urmărirea polară nu pot fi active în acelaşi timp
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§ 2.4 Modul ORTHO, SNAP, GRID, POLAR TRACKING

 Ajută la executarea desenelor la 
alte unghiuri decât cele ortogonale

 Direcţia de aliniere şi o etichetă 
(tooltip) sunt afişate 
atunci când cursorul se apropie de 
unghiurile specificate

 Pentru setarea unghiurilor:
 Tools>Drafting Settings

 click dreapta de la mouse pe butonul 
POLAR din bara de stare şi selectarea 
"Settings…"

Urmărirea polară (polar tracking)

 Incrementele unghiurilor pot fi de 0, 
60, 45, 30, 22.5, 18, 15, 10, sau 5 
grade, sau la intervale specificate 
de utilizator

 Pentru activare/dezactivare se 
foloseşte tasta F10 sau butonul 
POLAR din bara de stare
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 Ajută la specificarea precisă a punctelor cu ajutorul mouse-ului

 SNAP: restricţionează mişcarea cursorului la intervale specificate de-a 
lungul axelor X şi Y

Modul SNAP

 Setarea:

 Tools>Drafting settings

 sau click pe dreapta de la 
mouse pe butonul SNAP 
din bara de stare şi selectarea 
"Settings…„

 Activarea/dezactivarea:

 tasta F9

 butonul SNAP din bara de stare

 Tools>Drafting settings

§ 2.4 Modul ORTHO, SNAP, GRID, POLAR TRACKING

OBS. - Punctele de SNAP sunt invizibile
- Este posibilă rotirea reţelei de 
snap cu un unghi, precum şi 
schimbarea originii
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 Caroiajul (GRID): un caroiaj rectangular de puncte care umple o 
suprafaţă specificată prin limitele desenului. Caroiajul ajută la alinierea 
obiectelor şi la vizualizarea distanţelor dintre acestea.SNAP: 
restricţionează mişcarea cursorului la intervale specificate de-a lungul 
axelor X şi Y

GRID

 Setarea:

 Tools>Drafting settings

 sau click pe dreapta de la 
mouse pe butonul GRID
din bara de stare şi selectarea 
"Settings…„

 Activarea/dezactivarea:

 tasta F7

 butonul GRID din bara de stare

 Tools>Drafting settings

§ 2.4 Modul ORTHO, SNAP, GRID, POLAR TRACKING

OBS. Pasul caroiajului nu este necesar 
identic cu cel al reţelei SNAP
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 Snap/Grid isometric 
 facilitează crearea vederilor isometrice

 doar simulează un desen spaţial, acesta fiind de fapt plan

 după setare, sunt disponibile trei planuri:

 Left (stânga). Aliniază snap-ul şi caroiajul după axe la 90 şi 150. 

 Top (sus). Aliniază snap-ul şi caroiajul după axe la 30 şi 150. 

 Right (dreapta). Aliniază snap-ul şi caroiajul după axe la 30 şi 90.

 schimbarea planului isometric:

 tasta F5 sau 

 CTRL+E

Modul SNAP - Tipul şi stilul de snap

 PolarSnap restricţionează mişcarea cursorului

la intervale (distanţe) polare specificate de utilizator.  
 Odată cu mişcare cursorului, o etichetă (tooltip) indică cel mai apropiat increment 

PolarSnap. 

 Pentru a restricţiona introducerea distanţelor polare, trebuie să fie active atât urmărirea 
polară, cât şi modul snap. 

§ 2.4 Modul ORTHO, SNAP, GRID, POLAR TRACKING
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 Limitele desenului sunt definite de puncte în plan, specificate faţă de 
sistemul global de coordonate, care reprezintă colţurile stânga-jos şi 
dreapta-sus a suprafeţei de lucru.

 Dacă verificarea limitelor este activată (opţiunea On), introducerea 
coordonatelor este restricţionată la suprafaţa dreptunghiulară a 
limitelor. 

 Limitele determină şi suprafaţa desenului pe care este afişat caroiajul.

 Opţiuni:


 specificarea colţurilor (stânga-jos şi dreapta-sus)

 ON: AutoCAD nu permite introducerea coordonatelor 
în afara limitelor desenului

 OFF: dezactivează verificarea limitelor desenului 

§ 2.5 Limitele desenului

Specify lower left corner or [ON/OFF] <0.0000,0.0000>
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 AutoCAD-ul utilizează proceduri simple pentru crearea, deschiderea, 
închiderea şi salvarea desenelor:
 pentru a crea un desen nou: File>New (Ctrl+N)

 pentru deschiderea unui desen existent: File>Open (Ctrl+O)

 pentru închiderea unui desen: File>Close (Ctrl+F4)

 pentru salvarea unui desen: File>Save (Ctrl+S)

 pentru salvarea unui desen cu nume diferit: File>Save As (Ctrl+Shift+S)

 Șablonul (Template) este un fişier special care conţine setări standard şi 
obiecte, utilizate ca bază pentru desene noi.

 acad.dwt – un template simplu care conţine setările implicite imperial –
încărcate când setările "imperial settings" sunt folosite în tab-ul "Start 
from scratch“.

 acadiso.dwt - un template simplu care conţine stările implicite metrice -
încărcate când setările “metric settings” sunt folosite în tab-ul "Start 
from scratch“

§ 2.6 Crearea, deschiderea şi salvarea desenelor
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 Comanda:
 meniu: File>New
 tastatură: NEW

 NEW crează un desen nou. Depinde
de setările folosite inițial din meniul

§ 2.6 Crearea, deschiderea şi salvarea desenelor

Crearea unui desen nou folosind Template

Tools>Options>>System>>Startup:
 Afişează caseta de dialog: Create New Drawing. 

Pentru a utiliza un Template selectaţi "Use a 
template tab".

 Nu afişează caseta de dialog: Select Template (o 
casetă standard de dialog de selectare a 
fişierului).

Crearea unui desen folosind un Template implicit
 Comanda:

 Bara de unelte
 tastatură: QNEW

 QNEW începe un desen nou din template-ul curent implicit
 Template-ul implicit pentru comanda QNEW este specificat în:
Tools>Options>Files>Template Settings> Default Template File Name pentru QNEW


